Closed Bug 239821 Opened 17 years ago Closed 17 years ago

Additional spaces added to the To field if it has a colon

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: sooda, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi-FI; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla Thunderbird 0.5 (Windows/20040207)

When I'm composing a mail and have a colon in the "To" field, Thunderbird adds
additional spaces after that. It shouldn't do so and the additional spaces cause
some e-mail clients (including Thunderbird) to show the "To" field incorrectly
when reading the message sent with TB.

An example: XYZ:n porukka <XYZ@testi.fi> --> XYZ:  n porukka <XYZ@testi.fi>

Reproducible: Always
Steps to Reproduce:
1. Compose a mail with a colon in the To field.
2. Send it.
3. The receiver of the message views it and sees the oddity.

Actual Results:  
When viewing the headers of the sent message, they have additional spaces that
shouldn't be there. For example:
should be: XYZ:n porukka <XYZ@testi.fi>
but is: XYZ:  n porukka <XYZ@testi.fi>

Expected Results:  
Thundebird should not have added the spaces.

This issue might also be caused by a buggy SMTP server. However, I couldn't test
that since I only have access to one SMTP server from the system I'm using
Thunderbird on.
Is the "XYZ:" in that address actually a group designator?  
(See: <http://rfc.net/rfc2822.html#sA.1.3.>)
If not, the colon in the address is illegal.


I tried sending a message to two of my accounts as an RFC822 group:
  Grp:acct1@somewhere.tld, acct2@somewhereelse.tld;     <-- note semicolon 
(semicolon required for group address).

Thunderbird sent out the mail with the header:
  To: "Grp:acct1"@somewhere.tld, acct2@somewhereelse.tld;
      ~         ~  <-- note inserted quotes, but no spaces shoved into address

The first server sent back an error: no such user "Gacct1@somewhere.tld" which 
looks like an SMTP server error.  The second server received the error with the 
To: header as listed above.
I'm unable to reproduce the bug as described, and reporter had no response to 
comment 1, so => WFM
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.