Can't make pages both to Computer screens and handheld devices

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
19 years ago
19 years ago

People

(Reporter: tapio.markula, Assigned: troy)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
It would be extremely easy to create one page for both, IF
the browser support 'display:block' inside anchor links (like <a href="...><strong class="display:block">...).
MS IE 5.0 render
http://www.nic.fi/~tapio1/artsu-testi2.html (works only with MS IE 5.0)
quite the same as
http://www.nic.fi/~tapio1/artsu-testi.html (works at some level Mozilla 5.0 Gecko - the text drifs) and
http://www.nic.fi/~tapio1/artsu.html (text drifts)

Netscape 4.x with and without CSS support displays just text, but
upper links can't be read, if the CSS support is used. The idea
would be to give to handheld devices ONLY text witout CSS-support. But the idea works today only with MS IE 5.0.

Also with Mozilla 5.0 Gecko upper links can't be used. If this doesn't work,
the only possibility is to create pages with XML + XSLT.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 1

19 years ago
I don't understand what you're asking for and there's no URL or anything to
explain.

Are you saying that you there is a bug today that we don't allow blocks to be
inside anchor links? If so, a small example would be nice.

Or are you asking for the ability to specify "display:block" as the "class" for
an element inside of a A tag? I don't see what sense that makes

Marking INVALID. Please elaborate on what you're asking and then re-open
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 2

19 years ago
>+ ------- Additional Comments From troy@netscape.com  2000-01-14 14:39 -------
>+ I don't understand what you're asking for and there's no URL or anything to
>+ explain.

I made 2 test pages. Both of them should have similar visial stucture with CSS. There is one comparison page, which normal table structure and test pages without CSS.

http://www.nic.fi/~tapio1/artsu-testi.html

>+ Are you saying that you there is a bug today that we don't allow blocks to be
>+ inside anchor links? If so, a small example would be nice.

Belongs to my five test pages and here:
http://www.nic.fi/~tapio1/artsu-testi2b.html (the pages have 'flow' with 'display:block')

>+ Or are you asking for the ability to specify "display:block" as the "class" for an element inside of a A tag?

In order to get block-level links, also that. As you can see from my examples, without CSS-support the page could work in extremely small screens.
from
http://www.nic.fi/~tapio1/artsu-testi.html (Computer screen)
to
http://www.nic.fi/~tapio1/artsu-testi2b.html (handheld devices or terminals)
but it would need this to work:
http://www.nic.fi/~tapio1/artsu-testi2.html (better starting point to do this)
(Assignee)

Updated

19 years ago
Resolution: INVALID → ---
(Assignee)

Comment 3

19 years ago
Tapio, I'm marking this INVALID. We go over and over this, but I need you to
give me a SMALL test case that exhibits the problem.

I do not have time to compare two Web pages and guess at what the problem is.

Please provide a nice small test case. If you can't provide a small test case,
then re-open the bug but it's going to be very low priority then.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 4

19 years ago
Marking as INVALID (per previous comments) again. Tapio, please provide a simple
test case.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Marking verfied based on the last comments.
You need to log in before you can comment on or make changes to this bug.