Using <BS> (backspace) key sometimes jums back some undefined number of characters

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: sas, Unassigned)

Tracking

({perf})

Trunk
Other
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Mozilla: M12
BuildID: 1999122023
Machine: HP Vectra, 200MHz, 64MB and sufficient disk-space!

How to simulate?
1) Open any URL in Mozilla which has text entry field like this(bugzilla)
2) Enter some lines of text. While entering use <BS> (backspace) key
   multiple times

What happens?
1) Sometimes the <BS> key makes the cursor jump back some undefined
   number of characters and you find that you are erasing wrong text
2) The above is not always repeatable

3) Some more problems:
   i) You also find that, the cursor is very THICK and it is placed
   on the previous character when you will be typing the next
   character
   ii) Sometimes the <TAB> key doesnot move between fields

What should have happened:
1) The text input, cursor movement should be more uniform and sane
   Currently it is very un-predictable and makes the whold form filling
   a very bad experience.

Comment 1

19 years ago
This kind of problem can happen in any application if a keypress is 
(auto)repeated faster than its action can be repeated, and they get queued up,
due to slowdowns from inside or outside the app.

This problem has come and gone more than once, but it seems to be gone now.

Tested with:
2000-01-20-08-M13 nightly binary on Windows NT 4.0sp3 running on a P120 system.

Marking WORKSFORME; could not get this problem to reproduce.

The problems under (3) were also not seen using this build.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Component: Browser-General → Editor
Keywords: perf
QA Contact: nobody → sujay
Resolution: --- → WORKSFORME

Comment 2

19 years ago
verified in 1/24 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.