doesn't highlight first letter of search on first search in page

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: amos.shapira, Assigned: aaronlev)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Enter any page, start typing a phrase which is contained in that page.
The first letter will be looked up, but it won't be highlighted like the
rest of the search term.


Reproducible: Always
Steps to Reproduce:
1. load http://java.sun.com/j2se/1.4.2/docs/api/
2. start typing "runtime"

Actual Results:  
you'll find the "Runtime" interface line in the "All classes" frame in the
bottom left, but the "R" is not highlighted. It also doesn't show in the initial
search term when pressing CTRL-F.


Expected Results:  
Include the first letter in the search term - both for highlighting and when
pressing CTRL-F.


Happens to me both on Windows XP and Debian unstable on AMD.
Using Firefox 0.8.

Comment 1

15 years ago
Confirming (using a current CVS based trunk homemade build under WinXP-Sp1)

-> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040407
Firefox/0.8.0+ (MozJF)

Only happens with italic fonts. Try "robot" and it will be fully highlighted.

Related to bug 157788 ?
(Reporter)

Comment 2

15 years ago
I tried "robot" and still got the same behaviour - only "obot" was highlighted.

Also I forgot to add - this happens only in the FIRST incremental search after
the page is loaded. Second search and onwards are ok (even for italic font).

Thanks for handling this so quickly.

Comment 3

15 years ago
I also see this sometimes, but I'm not sure how to reproduce it.
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

15 years ago
I'm not seeing this in my current build:
Mozilla 1.8a2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040603
(Assignee)

Comment 5

15 years ago
What build are using?

(In reply to comment #2)
> I tried "robot" and still got the same behaviour - only "obot" was highlighted.
> 
> Also I forgot to add - this happens only in the FIRST incremental search after
> the page is loaded. Second search and onwards are ok (even for italic font).
> 

(Assignee)

Comment 6

15 years ago
I can't fix it if I can't reproduce any testcase.
Keywords: helpwanted

Comment 7

15 years ago
I just tried this in the page provided by the reporter. I cannot reproduce it
with Firefox 0.9RC, but I can reproduce using Firefox 0.8. Maybe this was fixed
in between.

Comment 8

15 years ago
I've just checked this with Firefox 0.9.2 on Windows XP and it seems to have
been fixed.
(Reporter)

Comment 9

13 years ago
Seems to have been fixed long ago.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 10

13 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.