Closed Bug 239956 Opened 21 years ago Closed 20 years ago

More subst fields for newchangedmail would be nice

Categories

(Bugzilla :: Email Notifications, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 70710

People

(Reporter: dave, Assigned: justdave)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

In support of general laziness, I've added a bunch of additional subst 
values to BugMail.pm, to allow increasing the verbosity/usefulness of 
bugzilla emails.

I added most of the fields that change regularly, so that we don't have to
browse to the bug to see what the status is, for example.  If there was a 
better way to do this (which seems likely) I didn't see it... 


In addition to the perl change, I added the following to newchangedmail:


----------------------------------------------------------------------------
Current Bug Details:
Hardware:  %platform%
Component: %component%
Severity:  %severity%
Priority:  %priority%
Target Milestone: %milestone%
Status:  %status%
Resolution:  %resolution%



Reproducible: Always
Steps to Reproduce:
My changes to BugMail.pm, on the off chance that this is seen as useful  :)
That might indeed be useful for someone in the short term...  in the medium term
(like very shortly after 2.18 branches) the mail stuff is all getting
templatized on the trunk, which will mean anything the template system can be
coerced to access will be fair game.
Thanks for the bug report. This particular bug has already been reported into
our bug tracking system, but please feel free to report any further bugs you find.

*** This bug has been marked as a duplicate of 70710 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: