Status

RESOLVED INCOMPLETE
15 years ago
4 years ago

People

(Reporter: kberk.spamaway, Unassigned)

Tracking

Details

(Whiteboard: [bug248549notfixed], URL)

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

In Firefox .8 and Mozilla 1.7b (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7b) Gecko/20040316), clicking through the menu items to retrieve differnet
areas of the ideazon.com website causes images to stop appearing.  They will
work the first time you go to ideazon.com, but when you start clicking around to
navigate the site, the images stop being displayed.

I'll attach some screenshots.

Opera 7.23 has the same problem.  IE 6 SP1 works fine.

Reproducible: Always
Steps to Reproduce:
1.  In Firefox .8 or Mozilla 1.7b, browse to ideazon.com
2.  Start clicking the News, Shop, Support, and Downloads links (it is actually
a flash menu).
3.  Eventually as the browser switches to the different pages images will stop
being displayed.



Expected Results:  
Images to be displayed consistantly.
(Reporter)

Comment 1

15 years ago
Created attachment 145659 [details]
Image from Firefox .8 showing the problem.
(Reporter)

Comment 2

15 years ago
Created attachment 145660 [details]
Image from Mozilla 1.7b showing the problem
(Reporter)

Comment 3

15 years ago
Created attachment 145661 [details]
Image from Opera 7.23 showing the problem
(Reporter)

Comment 4

15 years ago
Created attachment 145662 [details]
But IE 6 SP1 works fine
(Reporter)

Comment 5

15 years ago
This is a problem on Linux Mandrake 10 Community too, not just in Windows XP

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
OS: Windows XP → All

Comment 6

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040410

I looked at the shop. When I opened a frame in a new tab, I noticed an invalid
URL: http://www.ideazon.com/newWebSite/shop%5Cshop.htm

This is http://www.ideazon.com/newWebSite/shop\shop.htm, and mozilla can load
it, but I highly suspect the images are having also backslashs, as I saw this
error sometime ago at microsoft.com. 3 of 5 images weren´t shown, because of
this. But when I copy the link of the image, it looks correct. Maybe it´s wrong
on the server, or Mozilla automatically switches \/, don´t know.

As the shop address contains a backslash, and the server is IIS-5.0, I suspect
this bug is a tech evangelism bug.

The URL below was copied from the non-showing website, and also gives a 404

http://www.ideazon.com/images/misc/banners/USflag.gif

This is the mozilla extension: http://livehttpheaders.mozdev.org/

I´m getting a lot of 404 Errors, showing some Messages from Mozilla Extension
LiveHTTPheaders. First request is shown full, others I shortened, as the header
send is always the same.

This gif gave a 404 on the main site, but was found some requests later:

http://www.ideazon.com/images/misc/spacer.gif

GET /images/misc/spacer.gif HTTP/1.1
Host: www.ideazon.com
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040410
Accept: image/png,*/*;q=0.5
Accept-Language: en-us,fr-fr;q=0.8,de-de;q=0.5,es;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive

HTTP/1.x 404 Object Not Found
Server: Microsoft-IIS/5.0
Date: Sun, 11 Apr 2004 21:00:42 GMT
Connection: close
Content-Length: 4040
Content-Type: text/html
----------------------------------------------------------
http://www.ideazon.com/newWebSite/images/misc/spacer.gif

GET /newWebSite/images/misc/spacer.gif HTTP/1.1
Host: www.ideazon.com
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040410
Accept: image/png,*/*;q=0.5
Accept-Language: en-us,fr-fr;q=0.8,de-de;q=0.5,es;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive

HTTP/1.x 200 OK
Server: Microsoft-IIS/5.0
MicrosoftOfficeWebServer: 5.0_Pub
Date: Sun, 11 Apr 2004 21:00:45 GMT
Content-Type: image/gif
Accept-Ranges: bytes
Last-Modified: Tue, 09 Dec 2003 16:27:10 GMT
Etag: "fc41c74b71bec31:9c3"
Content-Length: 45
----------------------------------------------------------
http://www.ideazon.com/images/misc/shop-top.gif

GET /images/misc/shop-top.gif HTTP/1.1
Host: www.ideazon.com

HTTP/1.x 404 Object Not Found
Server: Microsoft-IIS/5.0
Date: Sun, 11 Apr 2004 21:06:51 GMT
Connection: close
Content-Length: 4040
Content-Type: text/html
----------------------------------------------------------
http://www.ideazon.com/images/misc/banners/USflag.gif

GET /images/misc/banners/USflag.gif HTTP/1.1
Host: www.ideazon.com


HTTP/1.x 404 Object Not Found
Server: Microsoft-IIS/5.0
Date: Sun, 11 Apr 2004 21:06:51 GMT
Connection: close
Content-Length: 4040
Content-Type: text/html
----------------------------------------------------------
http://www.ideazon.com/images/misc/banners/CAflag.gif

GET /images/misc/banners/CAflag.gif HTTP/1.1
Host: www.ideazon.com

HTTP/1.x 404 Object Not Found
Server: Microsoft-IIS/5.0
Date: Sun, 11 Apr 2004 21:06:53 GMT
Connection: close
Content-Length: 4040
Content-Type: text/html
----------------------------------------------------------
http://www.ideazon.com/images/shop/amazon.gif

GET /images/shop/amazon.gif HTTP/1.1
Host: www.ideazon.com

HTTP/1.x 404 Object Not Found
Server: Microsoft-IIS/5.0
Date: Sun, 11 Apr 2004 21:06:53 GMT
Connection: close
Content-Length: 4040
Content-Type: text/html
----------------------------------------------------------
http://www.ideazon.com/images/shop/NCIX.gif

GET /images/shop/NCIX.gif HTTP/1.1
Host: www.ideazon.com

....


HTTP/1.x 404 Object Not Found
Server: Microsoft-IIS/5.0
Date: Sun, 11 Apr 2004 21:07:00 GMT
Connection: close
Content-Length: 4040
Content-Type: text/html
----------------------------------------------------------
http://www.ideazon.com/images/shop/PCperfoParts.gif

GET /images/shop/PCperfoParts.gif HTTP/1.1
Host: www.ideazon.com
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040410
Accept: image/png,*/*;q=0.5
Accept-Language: en-us,fr-fr;q=0.8,de-de;q=0.5,es;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive

HTTP/1.x 404 Object Not Found
Server: Microsoft-IIS/5.0
Date: Sun, 11 Apr 2004 21:07:02 GMT
Connection: close
Content-Length: 4040
Content-Type: text/html
----------------------------------------------------------

and a lot more of them. 

Trying http://www.ideazon.com/images/shop/PCperfoParts.gif directly also gave a 404.



Comment 7

15 years ago
Image address copied from Opera 7.50:
http://www.ideazon.com/newWebSite/images/misc/banners/USflag.gif

Image adress copied from Mozilla´s broken image symbol:
http://www.ideazon.com/images/misc/banners/USflag.gif

Comment 8

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040402
testing on a faster computer, Win98SE

SHOP was working, SUPPORT was missing images.
Copied image adress from the broken symbol into location bar, got 404.

http://www.ideazon.com/images/misc/banners/zboardBanner.gif

inserted newwebsite, got image:
http://www.ideazon.com/newwebsite/images/misc/banners/zboardBanner.gif

Seems that website is in a transition 
from ideazon.com/... to ideazon.com/newwebsite/...

Comment 9

15 years ago
Frome Home to Support: the frameset changes

http://www.ideazon.com/newWebSite/support/supportFrameset.htm
http://www.ideazon.com/newWebSite/support/support/support.htm

From NEWS to Support: only a frame changes, and that frame contains backslashs:

http://www.ideazon.com/newWebSite/support%5Csupport%5Csupport.htm

Downloading that frames gave me names of support.htm and support_support_support.htm

urls o images inside these files are the same:
<img src="../images/support/support-servicestop.gif" width="593" height="40">
<img src="../../images/misc/spacer.gif" width="100" height="5">
<img src="../../images/misc/banners/zboardBanner.gif" width="140" height="381">

Any page is working from HOME, no page is working from any other page than HOME.

Bug is either Tech Evangelism or Invalid.

Comment 10

15 years ago
I'm moving this to TE.
Page http://www.ideazon.com/newWebSite/support%5Csupport%5Csupport.htm relys on
the fact IE uses %5C as a separator for directories.
Page http://www.ideazon.com/newWebSite/support/support/support.htm seems to be
the exact same page but with the correct separators.
All they need to do is change their links
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
Product: Browser → Tech Evangelism
Version: Trunk → unspecified

Updated

15 years ago
Assignee: general → english-other
Component: English US → English Other
QA Contact: general → english-other

Updated

14 years ago
Whiteboard: [bug248549notfixed]
is this now fixed ?

Comment 12

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.