sorting of domains should be top level down in cookie manager

VERIFIED DUPLICATE of bug 142179

Status

()

Core
Networking: Cookies
--
enhancement
VERIFIED DUPLICATE of bug 142179
14 years ago
14 years ago

People

(Reporter: Alex K, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

In the cookie manager the cookies are displayed alphabetically, which is
annoying to see all the amazon.com cookies since some are amazon.com others are
www.amazon.com and yet more could be under something else? ads.amazon.com for
example.

I suggest a new sorting algorithm that uses the last level of the domain and
then works its way back so all the .com's at the start so the ordering would
look like this...

amazon.com
ads.amazon.com
www.amazon.com
fark.com
cgi.fark.com
www.fark.com
img.fark.com

etc...


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 142179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
V/dupe.
If that bug's summary was not descriptive enough, please email me so we can fix it.
Status: RESOLVED → VERIFIED
QA Contact: core.networking.cookies → benc
You need to log in before you can comment on or make changes to this bug.