table in this page incorrectly off right edge of page when fonts are small

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Core
Layout
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: john nystrom, Assigned: Daniel.S)

Tracking

({testcase})

Trunk
mozilla1.9.2a1
x86
Windows 2000
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316

The web page's layout looks fine without the font-family property used.  If
font-family is used with Arial, Helvitica, Courier, and others (got it to work
with lithograph) the layout of the first table in my page shifts all the way to
the right.  I have another table below the shifted table, and it has correct
layout.I have the page in a div which has a width of 950px.  If I use the
default of Times New Roman it works fine.  This does not heppen in IE 6.0.  I am
using Mozilla 1.7B, and have tested on 1.6.

Reproducible: Always
Steps to Reproduce:
1.CSS file with font-family property in the body class or top level div
2.have a table within a div, the first table
3.use Arial as the font.

Actual Results:  
THe table should be shifted all the way to the right.

Expected Results:  
been aligned with the other content on the page.

theme of modern.
(Reporter)

Comment 1

14 years ago
The actual font selected in the font-family CSS property is rendered correctly,
the page is just shifted to the right.
There's no URL and no attached HTML.  Marking invalid.  Please reopen if you
provide an example.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

14 years ago
Just found out that the layout will correct itself if you enlarge the font size
on the browser, from "normal"......very strange.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

14 years ago
There's still no URL and no attached HTML. Please attach a testcase.
(Reporter)

Comment 5

14 years ago
Created attachment 145697 [details]
the css file.
(Reporter)

Comment 6

14 years ago
Created attachment 145698 [details]
HTML example that uses the CSS file attachment
(Reporter)

Comment 7

14 years ago
Added an example HTML and CSS file. like I said before, if you enlarge the size
of the text on the browser it will line up.  In the example everything should
line up, and the first table is shifted to the right.
Created attachment 145702 [details]
HTML + CSS in one file

Since attachment 145698 [details] doesn't link to attachment 145697 [details], but rather to
testCSS.css (which doesn't exist), here's the same thing but with a style
element instead of a linked stylesheet.
Attachment #145697 - Attachment is obsolete: true
Attachment #145698 - Attachment is obsolete: true
Created attachment 145705 [details]
simplified testcase

This is the previous file, modified so that almost all the stuff not needed to
show the bug has been removed.	(This is what we want in a testcase.)
Attachment #145702 - Attachment is obsolete: true
(Reporter)

Comment 10

14 years ago
What are you talking about?  THe files should link that I attached, and I dont
know what your testcase is, since it does not even have the font-family property
in it.  COuld you please clarify what you want???
(Reporter)

Comment 11

14 years ago
I see that David first made the CSS inline into the HTML, that is fine, it did
link before, but that is fine.  That one file does show the problem we are
expericencing.  The last attachment does not show the problem at all.  So need
to know if this is being worked on, or if there is a work around???
The bug doesn't have anything to do with the 'font-family' property itself, but
it does have something to do with the size of the fonts, which is influenced by
the 'font-family' property, among others.  I don't see the problem in attachment
145702 [details] at my default font sizes, but I do if I reduce them.  However, I do see
the problem in attachment 145705 [details] at my default font sizes.
Summary: font-family property in CSS1 affects the layout of web page with tested fonts of Arial, Helvitica, Courier → table in this page incorrectly off right edge of page when fonts are small
(Reporter)

Comment 13

14 years ago
ok, so u see the problem, I am running my text size at 100%.  So is this a known
bug?  IE 6.0 does not have this problem, just wondering if there is a way to fix
this on Mozilla without having to just use the default font.  We would like to
use Arial.  Thanks for any help....
This isn't a help system, it's a bug system.  Adding comments to the bug that
don't relate to fixing the bug in Mozilla just make the bug less likely to be
fixed, since the bug becomes harder to read.
(That said, looking at the handful of things that are still present in the
minimal testcase should show you some useful workarounds.)

Updated

14 years ago
Keywords: testcase
(Assignee)

Comment 16

10 years ago
The bug was visible in Fx2, but is not reproduceable for me in Fx3 or trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 17

9 years ago
Created attachment 354803 [details] [diff] [review]
reftest
[Checkin: Comment 20]

Here's a reftest based on your "simplified testcase".

In the reference the table got clearance which works everywhere. The "testcase" is only buggy in Firefox 2 but not 3 or trunk.
Attachment #354803 - Flags: superreview?
Attachment #354803 - Flags: review?
(Assignee)

Updated

9 years ago
Attachment #354803 - Flags: superreview?(dbaron)
Attachment #354803 - Flags: superreview?
Attachment #354803 - Flags: review?(dbaron)
Attachment #354803 - Flags: review?
This was a duplicate of bug 134706; I confirmed that it was fixed between Linux nightlies 2008-01-28-04-trunk and 2008-01-29-04-trunk.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 134706
Comment on attachment 354803 [details] [diff] [review]
reftest
[Checkin: Comment 20]

r+sr=dbaron
Attachment #354803 - Flags: superreview?(dbaron)
Attachment #354803 - Flags: superreview+
Attachment #354803 - Flags: review?(dbaron)
Attachment #354803 - Flags: review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Comment on attachment 354803 [details] [diff] [review]
reftest
[Checkin: Comment 20]

http://hg.mozilla.org/mozilla-central/rev/0f83e2505600
Attachment #354803 - Attachment description: reftest → reftest [Checkin: Comment 20]
Assignee: nobody → crazy-daniel
Depends on: 134706
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: DUPLICATE → FIXED
Target Milestone: --- → mozilla1.9.2a1
Serge, please do not check in test only patches with a comment "bug NNNNN - summary of bug".  Instead, use a comment that says you're adding tests for the bug (and, if you understand it, what the tests test).
Yes, I realized I should have done that just after pushing, but it was too late :-(
You need to log in before you can comment on or make changes to this bug.