Mark Drafts messages as unread

RESOLVED DUPLICATE of bug 67267

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 67267
14 years ago
10 years ago

People

(Reporter: Alec Flett, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
When you save a message as a draft, we should mark that message as unread. This
way it is obvious that you have drafts messages that are unfinished. I can't
tell you how often I go into my drafts folder to finish one message, and find
another one that I never did send.

I got this idea from Outlook, which does this. Other things that outlook does
with drafts that are interesting:
- Messages in the drafts folder are ALWAYS marked as unread - there is no
"preview pane," as they call it, when you click on the drafts folder. This means
you are forced to double-click the message to "read" it and thus continue your
composition. 
- A side effect of this is that there isn't any way to mark a draft message as
read. This means that the drafts folder is always bold until you've sent all the
messages in the folder. I'm not sure how I feel about that, because I think you
could easily start ignoring a bold drafts folder. In mozilla/thunderbird, at
least you can click in the unread flag column to mark the message as read.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 67267 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
I just reopened bug 198087 to see this bug readressed rather than duped.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.