USABILITY: Let the *user* control how to display PDF files

RESOLVED DUPLICATE of bug 58554

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 58554
14 years ago
14 years ago

People

(Reporter: Matthias Heiler, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Using the acrobat reader embedded within Mozilla under Linux is unreliable (see
plentora of bug reports), uncomfortable (less screen space for PDF's content)
and slow.  Besides, if I kill one embedded acroread, all others also die.

If I try to define an external PDF viewer in Preferences, Mozilla tells me:
"Mozilla can handle this type internally.  For such types, a Helper
Application will only be invoked if the server request external
handling."

In my opinion it's completely unacceptable that Mozilla claims to know better
than me, the user, how to display my PDF files. If the developers of Mozilla
prefer to view their PDFs embeddedly, fine.  Their choice.  But please let me
make my own choices.

Note that I already googled, found the workarounds which try to force Mozilla to
stop embedding acroread, but none worked for my und Linux.  (I'm not root on my
machine.)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
related: bug 147309

*** This bug has been marked as a duplicate of 58554 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.