pull-down menu in webpage not working probably

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Joe, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040407 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040407 Firefox/0.8.0+

In the page at
http://www.hkjcfootball.com/hk/english/match_info/team_results.asp, the "Lague"
and "Team" pull-down menus are not working probably. In IE6, after selecting
"League", the "Team" menu changes and display the team names coressponse to the
selected league. In Mozilla, the "Team" meanu does not responses to the
selection in "League" Menu. JavaScript Console showed some errors, I am not sure
if it is the mistake of the webpage or the javascript console itself(as I don't
know anything about javascript and the menus is working probably in IE6)

Reproducible: Always
Steps to Reproduce:
1.visit http://www.hkjcfootball.com/hk/english/match_info/team_results.asp
2.try to select any league from the "League" pull-down menu


Actual Results:  
"Team" pull-down menu does not change to display the team names coresponse to
the league selected

Expected Results:  
"Team" pull-down menu should show the coresponding team names. E.g. after
choosing "Premier" in "League" I can find "Arsenal" in "Team"

Javascript Console displayed quite a number of errors but I don't know how to
interpret them.
at line 19

tleague = document.mainform.league_no(index).value;
should be 
tleague = document.mainform.league_no[index].value; (square brackets)

which is why changing doesn't work.  Why IE supports that syntax is beyond me,
since that type of bracket belongs in function calls.

once that's done, the mainform.* calls around line 743 (see the JS console on
load) should be document.mainform instead (again, something IE supports but is
very out of spec)
per previous comments, resolving INVALID

I am submitting feedback to the site with regard to this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.