Borders (set with external CSS) disappear on a few TD elements when a Javascript file is included in one.

RESOLVED INVALID

Status

()

Core
Layout: Tables
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Russell, Unassigned)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7b) Gecko/20040408
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7b) Gecko/20040408

Borders (set with external CSS) disappear on a few TD elements when a Javascript
file is included in one.

Whilst build my site on my local network I had no problems with it at all, it
was only when I uploaded it to my web server did it start displaying the issue.
After some trouble shooting, it became apparent it was Javascript being included
that caused the problem.

Offending section:
<td colspan="2" id="date">
  <script src="script/dpdate.js" type="text/javascript"></script>
</td>
http://www.dynode.net/googleau.htm (might need to refresh this a couple of time
before the borders disappear)

Resolution:
<td colspan="2" id="date">&nbsp;
  <!-- <script src="script/dpdate.js" type="text/javascript"></script> -->
</td>
http://www.dynode.net/products.htm

While the script line is commented out (the non-breaking space is added for
expansion), my site renders as it should, but once the line is uncommented, it
breaks: the borders disappear and not just on the direct TD element, but also
the next TD element which is in a separate TR.

What's odd is the fact that this never happened while being developed on my home
network (gigabit), but only once uploaded to my web server where the download
speeds are slower: I could even reproduce the bug on my dads Windows XP machine,
running Mozilla 1.6 and connected to the Internet via dial-up--I believe it
might have something to do with rendering.

Reproducible: Always
Steps to Reproduce:
1.visit http://www.dynode.net/products.htm (Note the borders along the top and menu)
2.visit http://www.dynode.net/googleau.htm (If the borders are still there,
refresh a few times. If you're on very fast internet access, it may not work. I
use 512/128 ADSL and it does, Gigabit doesn't.)
Actual Results:  
Borders disappeared

Expected Results:  
Rendered the borders as it did whilst being produced on my home network.

Test cases:
Mozilla 1.6 on Windows XP
Mozilla 1.7b on FreeBSD 5.2.1-R

Comment 1

14 years ago
*** Bug 240103 has been marked as a duplicate of this bug. ***
This is almost certainly a border-collapse rendering bug, not a parser one.
Assignee: parser → nobody
Component: HTML: Parser → Layout: Tables
QA Contact: core.layout.tables
(Reporter)

Comment 3

14 years ago
Well, it loses the borders consistantly on both mine and my dad's computers when
`on-line', but when it's on my home server it renders fine.

Another note: while it's downloading, the borders are visible, but as soon as
the Javascript is in place, they disappear.

Comment 4

13 years ago
the provided urls dont work anymore

Comment 5

13 years ago
please reopen if a valid url/testcase is available
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.