Firefox writes URL file with no filename if <TITLE> tag is not specified.

RESOLVED DUPLICATE of bug 104933

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 104933
15 years ago
15 years ago

People

(Reporter: N. Thomas Posthuma, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When creating a URL file by draging the link anchor from the Address toolbar,
Firefox creates a file with no filename, just an extension, in Windows if the
<TITLE> tag is not specified in the HTML code of that page.

Reproducible: Always
Steps to Reproduce:
1. Drag the link anchor from the Address toolbar into a Windows Explorer folder
or Desktop
2. The link will contain no filename.

Actual Results:  
A URL file is created with no filename, even if the filename of the originating
document is known.

Expected Results:  
The expected result, failing the lookup for the <TITLE> tag in the HTML code,
Firefox should use the FQDN name (ie. www.petscii.com.url) if the document is
index.html on the root of a website or use filename for the page.
Further, if multiple periods are illegal on the filesystem of the client OS,
Firefox should use the Domain name (secondary portion) such as 'petscii.url' for
index.html, and use the filename without the extension, such as 'index.url'.

Creation of files with no filesname is bad practise.  Also, multiple attempts
from different websites would create files with the same name, asking for overwrite.
A test page is available at:
http://system7.no-ip.com/test.html showing that FireFox ignores the originating
document's filename if the <TITLE> tag is not specified.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 104933 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.