Personal Toolbar Folder stops loading and drop down (dialog) "sheets" hang (Add Bookmarks, Save Password, etc.)

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Jim Tuttle, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040408 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040408 Firefox/0.8.0+

I'm filing this is as a "Browser-General" bug, because I think it's more
pervasive than just the bookmark problem that usually shows up first.  In fact,
I think it's related to Bug #227524, but that's just a gut feeling based on some
of the symptoms.

Here's what happens.

After using Mozilla 1.7b (released and nightlies) or Firefox 0.8 (released or
nightlies) for some period of time (from a few minutes to a few hours), several
aspects of the Browser stop working.

In Firefox, I first notice the problem when opening a new window and the
Personal Toolbar is blank.  In Mozilla, the Personal Toolbar is still displayed,
but clicking on items doesn't cause anything to happen!

Additionally, if a dialog "sheet" (MacOS X term for a drop-down dialog box
that's associated with a given window (not a given application)) for something
like Add Bookmark or Save Password pops up, it is impossible to dismiss the
dialog sheet.  (I can still Quit the application, though.)

This happens EVERY time I run Mozilla or Firefox in MacOS X.  I've reinstalled
both apps and deleted profiles multiple times, to no avail.  I did not have this
problem w/ Mozilla 1.2.1 for MacOS Classic, nor with any Mozilla/Firefoxes on
Windows, Solaris, or Linux.

Reproducible: Sometimes
Steps to Reproduce:
This happens EVERY time I run Mozilla or Firefox in MacOS X.
Actual Results:  
Bookmarks broken; dialog "sheet" hangs.

Expected Results:  
Bookmarks should work; dialog sheets should not hang.

Comment 1

14 years ago
Jim,

Can you still reproduce this?

With Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2)
Gecko/20040525 Firefox/0.8.0+

I'm able to dismiss the bookmark sheet just fine.... with new windows my
personal toolbar appears by the time my homepage renders...
(Reporter)

Comment 2

14 years ago
I'm sorry I didn't respond to the question from "Riscky" back in May, but I didn't see his question until 
now (in Sept.).

Anyway, yes, not only did the problem not go away in rev 0.8, but it's still there in the 1.0 Preview 
Release!  I'm an avid supporter of Firefox on Windows, and I have to believe that it's working for many 
users in MacOS X, too, but this problem is a complete show-stopper for me.  No one else has seen this?

Dialog sheets work fine in other applications, I'm not sure why they start "freezing" in Firefox.  
Remember, the problem starts occuring after Firefox has been running for some time.  Doesn't have to 
be a very long time, but it never seems to have this problem when it first launches.  And, no, 
unfortunately, I can't correlate the behavior to any particular URLs or actions on my part (trust me - I've 
looked for some pattern).

Any help?

Comment 3

14 years ago
Jim,

When you add a bookmark cmd-d or via the menu with Firefox 1.0PR you can produce
this?

I just wonder because for me... bookmarks do not appear as a sheet.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040911
Firefox/0.10
(Reporter)

Comment 4

14 years ago
In Firefox 0.8, Bookmarks were added using a dialog "sheet".  In Firefox 1.0, I
see that they are now added using a traditional dialog "box".  It's a modal (?)
box - you can move it around the screen.  (Dialog sheets are a horrible
invention, by the way, simply because they are non-modal (?) and often block the
information you need!)

In Firefox 1.0, I've re-created this bug with the "Do you want Safari to
remember this password?" dialog sheet.  I installed Firefox yesterday, and
within a day this problem came up.

Comment 5

14 years ago
Jim,

Could you supply a screen shot of the dialog when it fails?

You don't receive the options of?
"Never for this site" "No" "Yes"
(Reporter)

Comment 6

14 years ago
Created attachment 159836 [details]
Screenshot of frozen Add Password dialog box
(Reporter)

Comment 7

14 years ago
I've attached a screenshot of the Add Bookmark dialog box hang.  I hadn't seen the freeze with Add 
Bookmark hang with 1.0, and thought (hoped) that it had gone away.  Obviously, my assumtion that it 
was tied to dialog sheets and not dialog boxes was wrong.

Also, this screenshot shows the "blank Personal Toolbar" portion of this bug.  Can you see how the 
section below all the icons is blank?  That's supposed to be filled with bookmarks and bookmark 
folders.

Just to confirm, this was a clean install of Firefox 1.0PR on a G4 1.25GHz (all previous preferences had 
been wiped out, to the best of ability and knowledge).  I believe I first had this bug under OS X 10.3.2, 
but I'm now running 10.3.5.

Any thoughts?  I've said it before - I love Firefox on Windows, and I'm dying to be able to use on MacOS, 
too!
Product: Browser → Seamonkey

Comment 8

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050426
Firefox/1.0+

I don't think that I have ever seen anything that quite matches this. Maybe 
it might happen in a system with a small amount of physical memory. In view of 
the passage of time, is it likely that this report will result in any 
improvement to Firefox. It is probably WORKSFORME.
(Reporter)

Comment 9

13 years ago
I have 768MB of RAM in a 1.25GHz G4 Mac.  So, RAM's not the issue.  This bug
(and others) drove me to use Safari on the Mac.  :-(

I will try using Firefox exclusively for a few days, and see if it's still
reproducible.
(Reporter)

Comment 10

13 years ago
I haven't seen this after using Firefox 1.0.3 for a few days.  Might as well
mark it as fixed so the team can concentrate on real bugs (like Bug 241398).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 11

13 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.