Bug 240137 (Sidebar_Enhancement)

Feature Request: Multiple Sidebars

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
15 years ago
14 years ago

People

(Reporter: yoweigh, Assigned: bugzilla)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Opening something new in the sidebar replaces what is already there. This seems
sort of stupid. I run my computer in a 1680x1050 resolution (widescreen baby)
and there's a ton of wasted space below the information in the sidebar. Even in
lower resolutions this is noticeable. Wouldn't it make more sense to be able to
have multiple panes of information in the sidebar? For example, I use the
Download Manager Tweak extension, and put my download manager in the sidebar. I
usually keep my bookmarks there (widescreen gives me some extra space on the
side) and they go away when the download manager pops up. This seems
unnecessary. I'd love to have my bookmarks AND my download manager over there,
along with anything else I decide to add later.

Reproducible: Always
Steps to Reproduce:
1. Open something in the sidebar.
2. Open something else in the sidebar.
3. First thing goes away!

Actual Results:  
Thuroughly explained in "Steps to Reproduce." Not too complicated.

Expected Results:  
1. Open something in the sidebar.
2. Open something else in the sidebar.
3. First thing stays, second thing appears below it.

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 for 80x86 	-TC -nologo -W3 -nologo -Gy
-Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 for 80x86 	-TP -nologo -W3 -nologo -Gy
-Fd$(PDBFILE)

Configure arguments
--disable-tests --disable-debug --enable-optimize --disable-shared
--enable-static --enable-crypto --disable-composer --disable-ldap
--disable-mailnews --disable-profilesharing
--enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices,inspector
--enable-static --disable-shared
(Reporter)

Comment 1

15 years ago
Just a feature request. Having multiple panes of info in the sidebar would be nice.
Alias: Sidebar_Enhancement
Keywords: polish
maybe an extension could implement something like this, for people with
real-world monitors this is useless and potentially confusing.   Unless you have
a monitor doing 1600x this is just going to take up too much space to make the
content usable.

Given that this wouldn't be usable by most people, thus making it poorly suited
for a core feature (see
http://www.mozilla.org/projects/firefox/ue/philosophy/realities.html), marking
WONTFIX, but it would make a potentially useful extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

15 years ago
I disagree with Mike's quick conclusion. Even in 1024x768, which is a pretty
commonly used resolution, a well organized set of bookmarks will leave the
sidebar 1/2 empty. At the very least, you should be able to have multiple panes
of information easily available without going through the menu route of
View->Sidebar. Mozilla accomplishes this through sidebar tabs. This seems to
work ok, but they are not present in Firefox.

Comment 4

14 years ago
*** Bug 289088 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.