Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: mike.hitchcock, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7b) Gecko/20040410
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7b) Gecko/20040410

This is a general bug that has occured on other sites as well but this example
demonstrates the bug. Want to download file PRNDRV.EXE from highlighted link
above. When selected with mouse a blank screen appears with the URL
http://www.cds-inc.com/pub/pmfax/prndrv.exe and no further progress is possible
although the browser is still active and you can back out of it

Reproducible: Always
Steps to Reproduce:
1.go to url http://www.cds-inc.com//techsprt/pmfaxodl.html
2.scroll down and double left click mouse on file PRNDRV.EXE
3.

Actual Results:  
new page is displayed which is blank ie background onl showing

Expected Results:  
Should have provided download directory selection box
(Reporter)

Comment 1

14 years ago
Tried same procedure using Netscape 4.61 fot OS/2 and was successful. Worked as
expected

Comment 2

14 years ago
WFM : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040402
Firefox/0.8.0+

Reporter, pls try with a new profile.

Comment 3

14 years ago
75KB downloaded in 0:17 using exact same build as reporter on eCS 1.14

Reporter, are you using any add-ins or non-stock skin?

Comment 4

14 years ago
Please answer the questions or I am going to close this.

also, were there errors in the Javascript console?

Did you try with a new profile?
(Reporter)

Comment 5

14 years ago
Another profile? I thought other profiles applied to mail only, not to the
browser. I tried changing to a different email addresss in mail bfore switching
to the browser

No add ons or non mozilla skins.

Javascript Console reports :-

stylesheet http://www.intradyn.com/index.html was loaded as CSS even though its
MIME type, "text/html", is not "text/css"

which I don't understand what it means

Comment 6

14 years ago
Select Tools->Switch Profile

Create a new profile then switch to it.

Then try the download again.
(Reporter)

Comment 7

14 years ago
Created new profile - switched to it - retried download - result the same as old
profile - blank screen and browser does not perform download

Comment 8

14 years ago
When the download fails, can you check the Javascript console at that time?
(Reporter)

Comment 9

14 years ago
As already reported

Javascript Console reports :-

stylesheet http://www.intradyn.com/index.html was loaded as CSS even though its
MIME type, "text/html", is not "text/css"

Comment 10

14 years ago
I was hoping for something different this time.

I have no idea what to do with this one. You are the only one that can recreate it.
(Reporter)

Comment 11

14 years ago
The bug is consistant even though I am updating to the latest nightly each day
Netscape 4.61 for OS/2 does the download ok and I have tried it successfully on
my laptop with an old 1.5 version of Warpzilla.

don't know if it helps but my system is a amd 233 mhz 128mb memory running Warp
4 fixpak 15 using the latest beta kernals tcp/ip 4.3 and java 1.31
(Reporter)

Comment 12

14 years ago
Just tried it with FireFox 0.8 and have exactly the same result as above and get
the same javascript Warning

Comment 13

14 years ago
dumb question.

Can you get the file dialog at all in Mozilla?

If you select file, save as - do you see a file dialog?
(Reporter)

Comment 14

14 years ago
No I don't get the file dialog - on the same page, in the same format are zip
files - if I select one of those I get the expected file dialog. When I  select
the file with the EXE extension I get a blank screen instead - when I
interrogate PAGE INFO under VIEW it shows the mime type as
application/octet-stream - does that help? I don't understand mime types

Comment 15

14 years ago
Acutally, I was wondering if you go to like www.yahoo.com and select File->Save
PAge As, do you get the file dialog.

I'm wondering if for some reason the file dialog isn't working under Mozilla on
your system at all.
(Reporter)

Comment 16

14 years ago
No problem with the file dialog as demonstrated by selecting a .zip extention. I
tried the "save page as" on yahoo and the file dialog did appear as expected.

I tried the old Netscape trick of holding down the shift key and selecting the
PRNDRV.EXE file and it worked!! the file dialog appeared and I was able to
download the file!!!

Comment 17

14 years ago
Can you also do about:plugins and tell me what plugins you have installed?
(Reporter)

Comment 18

14 years ago
Installed plug-ins
Find more information about browser plug-ins at Netscape.com.
Help for installing plug-ins is available from plugindoc.mozdev.org.
Mozilla Default Plug-in

    File name: npnulos2.dll
    Default Plug-in file

MIME Type 	Description 	Suffixes 	Enabled
* 	Mozilla Default Plug-in 	* 	Yes
WarpVision

    File name: npwv.dll
    WarpVision streaming plugin, http://os2.kiev.ua/en/wv.php

MIME Type 	Description 	Suffixes 	Enabled
audio/mpeg 	Audio MPEG 	mp3 	         Yes
video/mpeg 	Mpeg1 	mpg 	                 Yes
video/x-mpeg 	Mpeg2 	mpg 	                 Yes
video/x-mpeg2 	Mpeg 	mpeg 	                 Yes
video/x-msvideo 	avi 	avi 	         Yes
video/quicktime 	Quick Time 	mov 	 Yes
audio/x-ms-wax 	asf 	wax 	Yes
audio/x-ms-wma 	wma 	wma 	Yes
video/x-ms-asf 	wmv 	wmv 	Yes
video/x-ms-afs 	asf 	asf 	Yes
video/x-ms-wvx 	asf 	afs 	Yes
video/x-ms-wmv 	asf 	wmv 	Yes
video/x-ms-wma 	asf 	wma 	Yes
audio/x-pn-realaudio 	rm 	rm 	        Yes
application/x-ogg 	ogg/ogm 	og? 	Yes
application/octet-stream 		asf 	Yes
application/octet-stream 		avi 	Yes
application/octet-stream 		mp* 	Yes
application/octet-stream 		wm* 	Yes
InnoTek OS/2 Kit for Acrobat Reader 4.05

    File name: nparos2.dll
    Netscape Navigator Plug-in for InnoTek OS/2 Kit for Acrobat Reader 4.05

MIME Type 	Description 	Suffixes 	Enabled
application/pdf 	Acrobat 	pdf 	Yes
IBM Java(TM) Plug-in: J2RE 1.3.1 IBM build co131-20030618

    File name: npoji6.dll
    Java Plug-in 1.3.1 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;jpi-version=1.3.1 	OJI Plug-in 	* 	Yes
application/x-java-bean;jpi-version=1.3.1 	OJI Plug-in 	* 	Yes
application/x-java-applet;jpi-version=1.3.0_01 	OJI Plug-in 	* 	Yes
application/x-java-bean;jpi-version=1.3.0_01 	OJI Plug-in 	* 	Yes
application/x-java-vm/java-applet 	OJI Plug-in 	* 	Yes
application/x-java-vm 	OJI Plug-in 	* 	Yes
application/x-java-applet 	OJI Plug-in 	* 	Yes
application/x-java-applet;version=1.1 	OJI Plug-in 	* 	Yes
application/x-java-applet;version=1.1.1 	OJI Plug-in 	* 	Yes
application/x-java-applet;version=1.1.2 	OJI Plug-in 	* 	Yes
application/x-java-applet;version=1.1.3 	OJI Plug-in 	* 	Yes
application/x-java-applet;version=1.2 	OJI Plug-in 	* 	Yes
application/x-java-applet;version=1.2.1 	OJI Plug-in 	* 	Yes
application/x-java-applet;version=1.2.2 	OJI Plug-in 	* 	Yes
application/x-java-applet;version=1.3 	OJI Plug-in 	* 	Yes
application/x-java-bean 	OJI Plug-in 	* 	Yes
application/x-java-bean;version=1.1 	OJI Plug-in 	* 	Yes
application/x-java-bean;version=1.1.1 	OJI Plug-in 	* 	Yes
application/x-java-bean;version=1.1.2 	OJI Plug-in 	* 	Yes
application/x-java-bean;version=1.1.3 	OJI Plug-in 	* 	Yes
application/x-java-bean;version=1.2 	OJI Plug-in 	* 	Yes
application/x-java-bean;version=1.2.1 	OJI Plug-in 	* 	Yes
application/x-java-bean;version=1.2.2 	OJI Plug-in 	* 	Yes
application/x-java-bean;version=1.3 	OJI Plug-in 	* 	Yes
OS/2 Multimedia MIDI PlugIns

    File name: NPOS2MID.DLL
    OS/2 Multimedia MIDI PlugIns

MIME Type 	Description 	Suffixes 	Enabled
audio/x-mid 	OS/2 MM MIDI PlugIn 	mid,midi 	Yes
audio/x-midi 	OS/2 MM MIDI PlugIn 	mid,midi 	Yes
audio/midi 	OS/2 MM MIDI PlugIn 	mid,midi 	Yes
audio/x-mod 	OS2/2 MM MOD Plugin 	mod 	Yes
Proxy Plugin

    File name: NPPROXY.DLL
    Proxy Plugin DLL

MIME Type 	Description 	Suffixes 	Enabled
	Proxy Plugin 		Yes
OS/2 Multimedia Audio PlugIns

    File name: NPOS2AUD.DLL
    OS/2 Multimedia Audio PlugIns

MIME Type 	Description 	Suffixes 	Enabled
audio/x-iff 	OS/2 MM Audio PlugIn 	iff 	Yes
audio/x-voc 	OS/2 MM Audio PlugIn 	voc 	Yes
audio/x-aiff 	OS/2 MM Audio PlugIn 	aif,aiff 	Yes
audio/aiff 	OS/2 MM Audio PlugIn 	aif,aiff 	Yes
audio/basic 	OS/2 MM Audio PlugIn 	au,snd 	Yes
audio/x-wav 	OS/2 MM Audio PlugIn 	wav 	Yes
audio/wav 	OS/2 MM Audio PlugIn 	wav 	Yes
audio/x-mpeg 	OS/2 MM Audio Plugin 	mp2 	Yes
OS/2 Multimedia Video PlugIns

    File name: NPOS2VID.DLL
    OS/2 Multimedia Video PlugIns

MIME Type 	Description 	Suffixes 	Enabled
video/x-fli 	OS/2 MM Video PlugIn 	fli 	Yes
video/x-flc 	OS/2 MM Video PlugIn 	flc 	Yes
video/mpeg 	OS/2 MM Video PlugIn 	mpg,mpeg 	Yes
video/x-mpeg 	OS/2 MM Video PlugIn 	mpg,mpeg 	Yes
video/x-msvideo 	OS/2 MM Video PlugIn 	avi 	Yes
video/msvideo 	OS/2 MM Video PlugIn 	avi 	Yes
The Digital Sound & Music Interface for OS/2 Plug-in

(c) 1996, 1998 Theta Band Software LLC

http://www.thetaband.com/npdsmi

    File name: npdsmi.dll
    NPDSMI.DLL

MIME Type 	Description 	Suffixes 	Enabled
audio/x-amf 	Digital Sound & Music Interface modules 	amf 	Yes
audio/x-mod 	Amiga modules 	mod 	Yes
audio/x-s3m 	Scream Tracker 3 modules 	s3m 	Yes
audio/x-mtm 	MultiTracker modules 	mtm 	Yes
audio/x-stm 	Original Scream Tracker modules 	stm 	Yes
audio/x-far 	Farandole composer modules 	far 	Yes
audio/x-669 	Composer 669 modules 	669 	Yes
audio/x-nst 	Noise Tracker modules 	nst 	Yes
Could you try disabling the 'npwv.dll' plugin?  We're wondering if the
'application/octet-stream' is getting in the way.  And if that doesn't work, try
disabling your plugins one by one; perhaps one of those is causing your problem.
Hmm, I just downloaded the latest build of WarpVision and installed the plugin
myself.  However, when I loaded 'about:plugins', I didn't see any of the
'application/octet-stream' listings.  So you may also want to try downloading
the latest version of WarpVision.
(Reporter)

Comment 21

14 years ago
I think you have nailed it!!!

I disabled Warpvision NPWV.DLL plugin and rebooted and tried the download and
the download was successful!

I think this report can be closed now.

Thanks for all your time and help

Mozilla/Warpzilla is a magnificent achievement! thank you all for all your hard work

Comment 22

14 years ago
Excellent.

Glad we could help you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Did you try the new version of NPWV.DLL?
(Reporter)

Comment 24

14 years ago
Yes I have installed the newer npwv.dll plugin and it does not cause the error.

Thanks again
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.