Allow users with canconfirm to open bugs as UNCO from guided entry

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
15 years ago
6 years ago

People

(Reporter: ali, Assigned: gerv)

Tracking

Details

(Reporter)

Description

15 years ago
If someone has canconfirm privelidges, and they enter a bugreport using the
guided entry form (http://bugzilla.mozilla.org/enter_bug.cgi?format=guided) then
the bug is always opened as NEW.

The guided entry should give these users an option to open bugs as UNCO rather
than NEW (but I suppose still default to NEW).

Comment 1

15 years ago
this doesn't hurt average users as they don't have canconfirm, so i'd argue that
the added complexity is harmless. it might mean i'd actually use guided (well,
it might, you never know).
Assignee: myk → gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
Ali: why do you think they should be able to do this? People with canconfirm
tend to use the normal bug filing page anyway.

timeless: added complexity is never harmless, and particularly not for the
guided bug entry page, which is already more complicated than it would ideally be.

Gerv
(Reporter)

Comment 3

15 years ago
(In reply to comment #2)
> Ali: why do you think they should be able to do this? People with canconfirm
> tend to use the normal bug filing page anyway.

I tend to use the advanced bugreport form on most occasions, however sometimes
there are bugs that have concrete steps to reproduce. For these bugs, the guided
form is perfect because it makes sure that even advanced users don't forget to
include important information. It also makes bugreports componentised and easy,
adding useful information like Build IDs without the user having to.

However, often these issues that do have concrete steps to reproduce are not
necessarily actually real bugs, and ideally someone would want to file them as
unconfirmed, so that a component owner or peer could decide if they were real
bugs (see bug 240141 for a good example). In this case, the reporter *has* to
use the advanced entry form to enter an unconfirmed bug even though the guided
entry form is a far more appropriate and useful template to have for these types
of bugs.

The advanced entry form is primarily useful for bugs like: "Need to update
version strings in foo.c" or other stuff that normal users will never come
across. Just because only advanced users file these bugs doesn't necessarily
mean that they don't file other bugs.

> timeless: added complexity is never harmless, and particularly not for the
> guided bug entry page, which is already more complicated than it would ideally be.

I'd argue that in this case, added complexity is not really harmful because the
control would be locked for users who do not have canconfirm. You could easily
move it somewhere out of the way and put a one-liner explanation saying that
normally users should not need to touch this.

Alternatively, just hide the control completely from users who don't have
canconfirm. Then only users who have canconfirm would be able to see the
control, and they would (I hope) know what to do with it.
I'm afraid I'm not going to fix this, for the reasons I gave. Sorry about that :-(

Gerv
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.