If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New message charset not applied to signature

RESOLVED DUPLICATE of bug 52248

Status

MailNews Core
Internationalization
RESOLVED DUPLICATE of bug 52248
14 years ago
9 years ago

People

(Reporter: Andrew Church, Assigned: smontagu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040316

When composing a new message, the signature file is always interpreted as
charset "us-ascii" even when the default charset is set otherwise.  If no
non-ASCII characters are typed into the message, it is sent with charset "us-ascii".

Reproducible: Always
Steps to Reproduce:
1. Compose signature in ISO-2022-JP (JIS).
2. Set mailnews.send_default_charset to ISO-2022-JP.
3. Open new message.

Actual Results:  
Signature is displayed in US-ASCII.
Sending message without typing any additional text into the subject or body
results in a Content-Type header of "us-ascii".

Expected Results:  
Signature should be displayed in ISO-2022-JP.
Sent message's Content-Type header should be "ISO-2022-JP".

Comment 1

14 years ago
If this is about a text signature: dup of bug 52248
If it's about html signature: dup of bug 138008
(Reporter)

Comment 2

14 years ago
Text signature.

*** This bug has been marked as a duplicate of 52248 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.