cannot unblock pop-ups from local files

RESOLVED DUPLICATE of bug 204328

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 204328
14 years ago
13 years ago

People

(Reporter: cesium, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113

You can't unblock pop-ups from local files. I have a file that I reference via a
"file:///" partial url.  That .html file opens windows.  Under certain
circumstances (see next bug report) netscape blocks the pop-up.  (I normally
block pop-ups in my perferences.)  If you then click on the "pop-up blocked"
icon, a dialog box shows up which would normally allow you to specify the URL of
a site that you wanted to allow pop-ups from.  In this case, that input box is
blank. I should be able to specify that the site whose name is zero length may
create pop-ups, or I should be able to specify that if I'm using the "file:"
protocol instead of the "http" protocol, then pop-ups are allowed.

Reproducible: Always
Steps to Reproduce:
1.  disable pop-ups in your preferences; display an icon when pop-ups are blocked.
1.5.  create a web page that causes netscape to think that a pop-up window was
created
2.  reference the page via a "file:///" url.
3.  run the javascript on the page until the pop-up blocked icon appears.
4.  Click on the pop-up blocked icon.  Try to leave most pop-ups disabled, but
not "file:///" pop-ups.

Actual Results:  
Could not allow pop-up from my files without enabling all pop-ups.

Expected Results:  
Allowed me (or provided better instructions) to enable pop-ups from my local files.

Note that if the bug is fixed whereby forms and anchors that specify a named
target window actuall appear in the named target window, then this wouldn't be a
problem.  Also, I'm about to submit a separate bug stating that the windows I
create are either always pop-up windows or are never pop-up windows.

There is a workaround available:  enable pop-ups in your preferences before
using a special local file and disable pop-ups afterward.

Comment 1

14 years ago
According to bug 177106, adding localhost doesn't work, adding local IP works.
(Try 127.0.0.1) Resolving as dup.

*** This bug has been marked as a duplicate of 177106 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Not a dup. http://localhost != file://

As a silyl workaround, you can add "scheme:file" in the manager.
The real solution is to make that more user friendly, and part of that is to
properly prefill it.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> Not a dup. http://localhost != file://
> 
> As a silyl workaround, you can add "scheme:file" in the manager.
> The real solution is to make that more user friendly, and part of that is to
> properly prefill it.

I agree: not a dup.  Prefilling would be great.  Note that I just typed
"scheme:file" into the dialog while editing preferences, and it kept the
"scheme" part.  When I did it again as part of interacting with the "pop-up
blocked" icon, it said "The web site scheme already exists in this list." (That
should have quotes or italics around the word "scheme", or it should tell me the
name of the site scheme that already exists.  :-)

Comment 4

14 years ago
Isn't this bug a dupe of bug 204328 ?
(Reporter)

Comment 5

14 years ago
Looks like a duplicate to me.  Thanks, Cs

*** This bug has been marked as a duplicate of 204328 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.