Closed Bug 240336 Opened 16 years ago Closed 16 years ago

error messag box, procedure entry point in xpcom.dll not found

Categories

(SeaMonkey :: Installer, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: _a_x_e_, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

when calling the page http://nuernberg.waslos.de I get an error box with the
message:

Der Prozedureinstiegspunkt "??ONS_ConvertUTF16toUTF8@@QAE@PBG@Z" wurde in der
DLL "xpcom.dll" nicht gefunden.

free english translation:

The Procedure/Function entrypoint "??ONS_ConvertUTF16toUTF8@@QAE@PBG@Z" could
not be found in "xpcom.dll".



Reproducible: Always
Steps to Reproduce:
1. just call http://nuernberg.waslos.de you ned NOT to login in to get the error
message

Actual Results:  
error message box appears, clicking ok, the website loading continues

Expected Results:  
show no error message
Sounds like you had some sort of extension installed and installed on top of a
previous Mozilla install.. and this extension does not like the string changes.
(In reply to comment #1)
> Sounds like you had some sort of extension installed and installed on top of a
> previous Mozilla install.. and this extension does not like the string changes.

no, that was the first advice in a forum to check this, but I can completly
uninstall mozilla, delete the mozilla install directory, freshly install mozilla
1.7b create e NEW profile and I get the same erro. More freshly an installation
cant' be.
Did you also removed c:\program files\common files\mozilla.org ?
(In reply to comment #3)
> Did you also removed c:\program files\common files\mozilla.org ?

Sorry! I found the problem, npmozax.dll in my plugin-dir, which was not deleted
because it was somehow in use. don't ask me where it came from. no everything
works fine. sorry for bug-opening.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
*** Bug 241508 has been marked as a duplicate of this bug. ***
*** Bug 237978 has been marked as a duplicate of this bug. ***
*** Bug 239147 has been marked as a duplicate of this bug. ***
*** Bug 239625 has been marked as a duplicate of this bug. ***
*** Bug 241817 has been marked as a duplicate of this bug. ***
v
Status: RESOLVED → VERIFIED
Er... shouldn't the installer handle this?  I'm reopening this bug until we sort
out exactly why files that should have been deleted were not.
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
Assignee: dougt → general
Status: UNCONFIRMED → NEW
Component: XPCOM → Installer
Ever confirmed: true
Flags: blocking1.7?
QA Contact: bugzilla
This bug report is about the activeX plugin which must be use unfrozen
interfaces (see comment#4)

And "invalid" seems to be the correct solution for *this* bug report
Ah, I see.  Ok, yeah.  That's invalid.  It wasn't clear that npmozax is the
ActiveX control.
Status: NEW → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → INVALID
*** Bug 242100 has been marked as a duplicate of this bug. ***
Flags: blocking1.7?
*** Bug 248167 has been marked as a duplicate of this bug. ***
*** Bug 248257 has been marked as a duplicate of this bug. ***
*** Bug 248223 has been marked as a duplicate of this bug. ***
This bug is fixed if the correct version of npmozax.dll, the ActiveX plugin, is
used. The npmozax.dll in the Mozilla ActiveX Control v1.7t1, dated 13 April
2004, works.

Download the control, install it and then copy the dll from the controls'
Plugins dir to Mozilla's Plugins dir.

http://www.iol.ie/~locka/mozilla/MozillaControl17t1.exe
*** Bug 250071 has been marked as a duplicate of this bug. ***
*** Bug 252472 has been marked as a duplicate of this bug. ***
I re-installed several times, deleting more and more files&directories prior to
each install.  Not until I deleted every file/folder with the word mozilla did
the install produce a version free of this  bug.  That shouldn't be necessary.
If you got the same entry point error as the reporter, you had the Mozilla
ActiveX Plugin installed. It's the fault of the plugin and not something in Mozilla.
Product: Browser → Seamonkey
*** Bug 276828 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.