No hotkeys to scroll while in composer

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: boofy_bloke, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

and Page Up/Down moves the caret.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
I am not sure about what you're asking for or commenting on. Please always state
clear description of the problem or issue, explicit steps to reproduce, expected
results, actual results, an URL if possible and/or a reduced testcase if suitable.

Bug writing guidelines:
http://www.mozilla.org/quality/bug-writing-guidelines.html

Empirical discoveries in Windows XP: Home/End will navigate to beginning/end of
an element, inside an element. Ctrl+Home/Ctrl+End will navigate to beginning/end
of the editable section of a document currently in Composer.

Comment 2

14 years ago
Help/Help Contents/Contents tab/Mozilla Keyboard Shortcuts/General Mozilla
Shortcuts gives (for Windows):

Go Up One Page:	Page Up
Go Down One Page: Page Down
Go Up One Line:	Up Arrow
Go Down One Line: Down Arrow 
(...)
Move to beginning of line (in a text editing field): Home 
Move to end of line (in a text editing field): End 

and these general Mozilla shortcuts apply to Composer.

Ctrl+End will move caret to the end of document in Composer.
Rolling the mousewheel also navigate up/down in the document in Composer.

I'm resolving this bug as INVALID because, as I understood your bugfile
description, there are keyboard hotkeys to navigate up/down in the document
while in Composer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

14 years ago
The first part of the message was cut off.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041101

Problem: There is no way to page up/down in Composer without moving the cursor.
Sometimes I have text selected at the top of the page then want to have a look
at something at the bottom of the page. The only way to do so using the keyboard
results in losing the "selection-ness" at the top of the page as the cursor
moves around. I could scroll down with the mouse but I try to avoid using it.
Netscape 4.8 uses CTRL+PAGE UP/DOWN to move the page but not the cursor.

I guess that this is a request, not a bug.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.