trying to add `^Icore.spelling-checker@bugs` to watch list caused unfriendly error messages

VERIFIED DUPLICATE of bug 240036

Status

()

Bugzilla
Email Notifications
VERIFIED DUPLICATE of bug 240036
14 years ago
6 years ago

People

(Reporter: timeless, Assigned: justdave)

Tracking

2.17.6
x86
Windows 2000

Details

(Reporter)

Description

14 years ago
Bugzilla has suffered an internal error. Please save this page and send it to
myk@mozilla.org with details of what you were doing at the time this message
appeared.

URL: http://bugzilla.mozilla.org/userprefs.cgi

Template->process() failed twice.
First error: undef error - DBD::mysql::st execute failed: Table 'namedqueries'
was not locked with LOCK TABLES [for statement `` SELECT name, query,
linkinfooter FROM namedqueries WHERE userid=? ORDER BY UPPER(name)'']) at
Bugzilla/User.pm line 156
Bugzilla::User::queries('Bugzilla::User=HASH(0x859661c)') called at
data/template/template/en/default/global/site-navigation.html.tmpl line 143 eval
{...} called at
data/template/template/en/default/global/site-navigation.html.tmpl line 143 eval
{...} called at
data/template/template/en/default/global/site-navigation.html.tmpl line 16
Template::Provider::__ANON__('Template::Context=HASH(0x8514dc8)') called at
Template/Document.pm line 140 eval {...} called at Template/Document.pm line 138
Template::Document::process('Template::Document=HASH(0x86c3d70)',
'Template::Context=HASH(0x8514dc8)') called at Template/Context.pm line 343 eval
{...} called at Template/Context.pm line 320
Template::Context::process('Template::Context=HASH(0x8514dc8)',
'global/site-navigation.html.tmpl') called at
data/template/template/en/default/global/header.html.tmpl line 57 eval {...}
called at data/template/template/en/default/global/header.html.tmpl line 16
Template::Provider::__ANON__('Template::Context=HASH(0x8514dc8)') called at
Template/Document.pm line 140 eval {...} called at Template/Document.pm line 138
Template::Document::process('Template::Document=HASH(0x86b4bb0)',
'Template::Context=HASH(0x8514dc8)') called at Template/Context.pm line 343 eval
{...} called at Template/Context.pm line 320
Template::Context::process('Template::Context=HASH(0x8514dc8)',
'global/header.html.tmpl') called at
data/template/template/en/default/global/user-error.html.tmpl line 2102 eval
{...} called at data/template/template/en/default/global/user-error.html.tmpl
line 16 Template::Provider::__ANON__('Template::Context=HASH(0x8514dc8)') called
at Template/Document.pm line 140 eval {...} called at Template/Document.pm line
138 Template::Document::process('Template::Document=HASH(0x868eef8)',
'Template::Context=HASH(0x8514dc8)') called at Template/Context.pm line 343 eval
{...} called at Template/Context.pm line 320
Template::Context::process('Template::Context=HASH(0x8514dc8)',
'Template::Document=HASH(0x868eef8)') called at Template/Service.pm line 97 eval
{...} called at Template/Service.pm line 94
Template::Service::process('Template::Service=HASH(0x84e3f50)',
'global/user-error.html.tmpl', 'HASH(0x861f678)') called at Template.pm line 76
Template::process('Bugzilla::Template=HASH(0x84d595c)',
'global/user-error.html.tmpl', 'HASH(0x861f678)') called at Bugzilla/Error.pm
line 44 Bugzilla::Error::_throw_error('global/user-error.html.tmpl',
'invalid_username', 'HASH(0x861f678)') called at Bugzilla/Error.pm line 51
Bugzilla::Error::ThrowUserError('invalid_username', 'HASH(0x861f678)') called at
globals.pl line 803 main::DBNameToIdAndCheck('^Icore.spelling-checker@bugs')
called at RelationSet.pm line 180
RelationSet::mergeFromString('RelationSet=HASH(0x8620c90)', '
^Icore.spelling-checker@bugs aaronleventhal@moonset.net,adamloc...') called at
RelationSet.pm line 55 RelationSet::new('RelationSet', '
^Icore.spelling-checker@bugs aaronleventhal@moonset.net,adamloc...') called at
/opt/webtools/bugzilla/userprefs.cgi line 250 main::SaveEmail() called at
/opt/webtools/bugzilla/userprefs.cgi line 328
Second error: undef error - DBD::mysql::st execute failed: Table 'namedqueries'
was not locked with LOCK TABLES [for statement `` SELECT name, query,
linkinfooter FROM namedqueries WHERE userid=? ORDER BY UPPER(name)'']) at
Bugzilla/User.pm line 156
Bugzilla::User::queries('Bugzilla::User=HASH(0x859661c)') called at
data/template/template/en/default/global/site-navigation.html.tmpl line 143 eval
{...} called at
data/template/template/en/default/global/site-navigation.html.tmpl line 143 eval
{...} called at
data/template/template/en/default/global/site-navigation.html.tmpl line 16
Template::Provider::__ANON__('Template::Context=HASH(0x8514dc8)') called at
Template/Document.pm line 140 eval {...} called at Template/Document.pm line 138
Template::Document::process('Template::Document=HASH(0x86c3d70)',
'Template::Context=HASH(0x8514dc8)') called at Template/Context.pm line 343 eval
{...} called at Template/Context.pm line 320
Template::Context::process('Template::Context=HASH(0x8514dc8)',
'global/site-navigation.html.tmpl') called at
data/template/template/en/default/global/header.html.tmpl line 57 eval {...}
called at data/template/template/en/default/global/header.html.tmpl line 16
Template::Provider::__ANON__('Template::Context=HASH(0x8514dc8)') called at
Template/Document.pm line 140 eval {...} called at Template/Document.pm line 138
Template::Document::process('Template::Document=HASH(0x86b4bb0)',
'Template::Context=HASH(0x8514dc8)') called at Template/Context.pm line 343 eval
{...} called at Template/Context.pm line 320
Template::Context::process('Template::Context=HASH(0x8514dc8)',
'global/header.html.tmpl') called at
data/template/template/en/default/global/code-error.html.tmpl line 942 eval
{...} called at data/template/template/en/default/global/code-error.html.tmpl
line 16 Template::Provider::__ANON__('Template::Context=HASH(0x8514dc8)') called
at Template/Document.pm line 140 eval {...} called at Template/Document.pm line
138 Template::Document::process('Template::Document=HASH(0x870b414)',
'Template::Context=HASH(0x8514dc8)') called at Template/Context.pm line 343 eval
{...} called at Template/Context.pm line 320
Template::Context::process('Template::Context=HASH(0x8514dc8)',
'Template::Document=HASH(0x870b414)') called at Template/Service.pm line 97 eval
{...} called at Template/Service.pm line 94
Template::Service::process('Template::Service=HASH(0x84e3f50)',
'global/code-error.html.tmpl', 'HASH(0x86a66a8)') called at Template.pm line 76
Template::process('Bugzilla::Template=HASH(0x84d595c)',
'global/code-error.html.tmpl', 'HASH(0x86a66a8)') called at Bugzilla/Error.pm
line 70 Bugzilla::Error::ThrowTemplateError('undef error - DBD::mysql::st
execute failed: Table \'namedqueries\' was not locked with LOCK TABLES [for
statement `` SELECT name, query, linkinfooter^J FROM namedqueries^J WHERE
userid=?^J ORDER BY UPPER(name)\'\']) at Bugzilla/User.pm line
156^J^IBugzilla::User::queries(\'Bugzilla::User=HASH(0x859661c)\') called at
data/template/template/en/default/global/site-navigation.html.tmpl line
143^J^Ieval {...} called at
data/template/template/en/default/global/site-navigation.html.tmpl line
143^J^Ieval {...} called at
data/template/template/en/default/global/site-navigation.html.tmpl line
16^J^ITemplate::Provider::__ANON__(\'Template::Context=HASH(0x8514dc8)\') called
at Template/Document.pm line 140^J^Ieval {...} called at Template/Document.pm
line 138^J^ITemplate::Document::process(\'Template::Document=HASH(0x86c3d70)\',
\'Template::Context=HASH(0x8514dc8)\') called at Template/Context.pm line
343^J^Ieval {...} called at Template/Context.pm line
320^J^ITemplate::Context::process(\'Template::Context=HASH(0x8514dc8)\',
\'global/site-navigation.html.tmpl\') called at
data/template/template/en/default/global/header.html.tmpl line 57^J^Ieval {...}
called at data/template/template/en/default/global/header.html.tmpl line
16^J^ITemplate::Provider::__ANON__(\'Template::Context=HASH(0x8514dc8)\') called
at Template/Document.pm line 140^J^Ieval {...} called at Template/Document.pm
line 138^J^ITemplate::Document::process(\'Template::Document=HASH(0x86b4bb0)\',
\'Template::Context=HASH(0x8514dc8)\') called at Template/Context.pm line
343^J^Ieval {...} called at Template/Context.pm line
320^J^ITemplate::Context::process(\'Template::Context=HASH(0x8514dc8)\',
\'global/header.html.tmpl\') called at
data/template/template/en/default/global/user-error.html.tmpl line 2102^J^Ieval
{...} called at data/template/template/en/default/global/user-error.html.tmpl
line 16^J^ITemplate::Provider::__ANON__(\'Template::Context=HASH(0x8514dc8)\')
called at Template/Document.pm line 140^J^Ieval {...} called at
Template/Document.pm line
138^J^ITemplate::Document::process(\'Template::Document=HASH(0x868eef8)\',
\'Template::Context=HASH(0x8514dc8)\') called at Template/Context.pm line
343^J^Ieval {...} called at Template/Context.pm line
320^J^ITemplate::Context::process(\'Template::Context=HASH(0x8514dc8)\',
\'Template::Document=HASH(0x868eef8)\') called at Template/Service.pm line
97^J^Ieval {...} called at Template/Service.pm line
94^J^ITemplate::Service::process(\'Template::Service=HASH(0x84e3f50)\',
\'global/user-error.html.tmpl\', \'HASH(0x861f678)\') called at Template.pm line
76^J^ITemplate::process(\'Bugzilla::Template=HASH(0x84d595c)\',
\'global/user-error.html.tmpl\', \'HASH(0x861f678)\') called at
Bugzilla/Error.pm line
44^J^IBugzilla::Error::_throw_error(\'global/user-error.html.tmpl\',
\'invalid_username\', \'HASH(0x861f678)\') called at Bugzilla/Error.pm line
51^J^IBugzilla::Error::ThrowUserError(\'invalid_username\', \'HASH(0x861f678)\')
called at globals.pl line
803^J^Imain::DBNameToIdAndCheck(\'^Icore.spelling-checker@bugs\') called at
RelationSet.pm line
180^J^IRelationSet::mergeFromString(\'RelationSet=HASH(0x8620c90)\', \'
^Icore.spelling-checker@bugs aaronleventhal@moonset.net,adamloc...\') called at
RelationSet.pm line 55^J^IRelationSet::new(\'RelationSet\', \'
^Icore.spelling-checker@bugs aaronleventhal@moonset.net,adamloc...\') called at
/opt/webtools/bugzilla/userprefs.cgi line 250^J^Imain::SaveEmail() called at
/opt/webtools/bugzilla/userprefs.cgi line 328^J') called at Bugzilla/Error.pm
line 44 Bugzilla::Error::_throw_error('global/user-error.html.tmpl',
'invalid_username', 'HASH(0x861f678)') called at Bugzilla/Error.pm line 51
Bugzilla::Error::ThrowUserError('invalid_username', 'HASH(0x861f678)') called at
globals.pl line 803 main::DBNameToIdAndCheck('^Icore.spelling-checker@bugs')
called at RelationSet.pm line 180
RelationSet::mergeFromString('RelationSet=HASH(0x8620c90)', '
^Icore.spelling-checker@bugs aaronleventhal@moonset.net,adamloc...') called at
RelationSet.pm line 55 RelationSet::new('RelationSet', '
^Icore.spelling-checker@bugs aaronleventhal@moonset.net,adamloc...') called at
/opt/webtools/bugzilla/userprefs.cgi line 250 main::SaveEmail() called at
/opt/webtools/bugzilla/userprefs.cgi line 328

*** This bug has been marked as a duplicate of 240036 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.