Browser temporarily hangs when download to network drive complete

RESOLVED DUPLICATE of bug 219099

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 219099
14 years ago
9 years ago

People

(Reporter: P Cocker, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6) Gecko/20040206 Firefox/0.8

When downloading a file to a slow(ish) network drive, I find that once the
download has completed, the browser will hang (browser window stops updating,
and you get the smudge effect if you run another window over it) until the file
has finished tranferring to the network drive.

This has only been tested with files of around 2-8MB (the latest Windows hotfixes)

Reproducible: Always
Steps to Reproduce:
1. Click file link
2. Choose network drive as save location
3. Click save
4. Wait for download to hit 100%
5. Try and use browser.  Move windows across it.

Actual Results:  
Computer continues to work fine, as do all applications, but the browser is
unusable until the file is on the network drive.

Expected Results:  
Possibly change status to show that the file is being moved to the network
drive.  Give some sign that this is expected behaviour, or better yet, continue
to respond.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 219099 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.