If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Message filters with action to move to folder with "@" or "!" in the name was corrupted again (Bug 229345 was regressed)

RESOLVED FIXED

Status

MailNews Core
Filters
--
major
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: World, Assigned: Jungshik Shin)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.31 KB, patch
Bienvenu
: review+
Scott MacGregor
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040414
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040414

Message filters, whose action is move to folder with "@" or "!" in the name, was
corrupted again - Bug 229345 was regressed.

(1) Already defined filters which point to folder name with "@" or "!" were
disabled.
(2) Newly created filter which point to folder name with "@" or "!" does not
escape "@" or "!" of action-value in msgFilterRules.dat.
This new filter works.
These are completely same symptom of Bug 229345.

2004-04-06 trunk nightly build has no problem. 
nsMsgUtils.cpp is the fixed source by bug 229345.
Change histry of nsMsgUtils.cpp by Bonsai ;
  2004-01-07 08:04 by bug 229345
  2004-04-12 21:07 by bug 229032


Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Additional information.
2004041208-trunk(Zip build)/Win-2K(SP4) does not have this problem.
Summary: Message filters with action to move to folder with "@" or "!" in the name was corrupted again (Bug 229345 was regressed) → Message filters with action to move to folder with "@" or "!" in the name was corrupted again (Bug 229345 was regressed)
(Assignee)

Comment 2

14 years ago
My patch for bug 229032 reverted back to NS_(Un)EscapeURL() from ns(Un)Escape.
I'll make a patch tomorrow. 
Assignee: sspitzer → jshin
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

14 years ago
Created attachment 146567 [details] [diff] [review]
patch

Sorry it took me so long. I made a filter moving mails to a folder with '@' in
its name with mozilla 1.6 and then tested it with the trunk build with this
patch applied. The filter worked fine.
(Assignee)

Comment 4

14 years ago
Comment on attachment 146567 [details] [diff] [review]
patch

asking for r/sr
Attachment #146567 - Flags: superreview?(mscott)
Attachment #146567 - Flags: review?(bienvenu)

Updated

14 years ago
Blocks: 240476

Comment 5

14 years ago
Comment on attachment 146567 [details] [diff] [review]
patch

I didn't see a change to any of the callers of this routine even though the
signature changed.

Comment 6

14 years ago
Comment on attachment 146567 [details] [diff] [review]
patch

the callers were probably already using things that were flat strings...
Attachment #146567 - Flags: review?(bienvenu) → review+

Comment 7

14 years ago
Comment on attachment 146567 [details] [diff] [review]
patch

ah thanks David
Attachment #146567 - Flags: superreview?(mscott) → superreview+

Comment 8

14 years ago
...although the callee isn't using it as a flat string anyway...

Comment 9

14 years ago
Ditto.

I have two folders starting with "!" -- when I install an nightly build, the
filters for those folders get disabled becasue the folders cannot be found.

Once I re-select the folders the filters work fine.
(Reporter)

Comment 10

14 years ago
(In reply to comment #9)

> I have two folders starting with "!" -- when I install an nightly build, the
> filters for those folders get disabled becasue the folders cannot be found.
> Once I re-select the folders the filters work fine.

Since patch caused this regression was applied at 21:07 on 2004-04-12 (by bug
229032), last working build is 2004-04-12 13:00 build(Win,Zip build).
And backout nor proposed patch is not applied on any nightlies yet.
Use builds after 1/07 & before 4/12 if you experienced filter disable problem.
(Reporter)

Comment 11

14 years ago
Oh no! 1.7 RC1 has been released without fix for this bug.
Severity: normal → major
(Reporter)

Updated

14 years ago
Flags: blocking1.7?
(Assignee)

Comment 12

14 years ago
My mega mailnews patch for bug 229032 wasn't landed in 1.7 branch. It was  only
for 1.8alpha. 
Flags: blocking1.7?

Comment 13

14 years ago
It is unclear from your statement which branch of the tree.  My nightly build
says "1.8a" but did the bug appear before the 1.7 and 1.8 branches diverged?

Comment 14

14 years ago
it did not. Also, some of the early 1.8 builds might have said 1.7 or 1.7b on
them...

Comment 15

14 years ago
jshin:
Would it make sense to ask "blocker1.7?" status and fix this for 1.7final, too ?

Comment 16

14 years ago
this bug is not in 1.7 - jshin's changes did not get checked into 1.7

Comment 17

14 years ago
removing from the 0.6 blocker list since this isn't in 1.7
No longer blocks: 240476
(Reporter)

Comment 18

14 years ago
Jungshik Shin, did you fix this bug? Or only partial fix?

I've found that Message filter for folder name ! or @ is escaped successfully
again on 2004050308-trunk/Win-2K.
 (I could not aware of problem solution since I already changed ! and @ )
 ( in all folders to $ in order to avoid this bug of my only mailer on 4/21. )
And Bonsai says you checked in patch for this bug to mozilla/ mailnews/ base/
util/ nsMsgUtils.cpp at 2004-04-21 03:39.
(Assignee)

Comment 19

14 years ago
sorry i forgot to mark this as fixed. fix checked in a while ago.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.