Crash when I attempt to browse above URL or view yenc files

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: glbras, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040224
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040224

This same GPF occurs in Netscape 7.1.

When I try to browse the listed URL or yenc files I get the following:

MOZILLA caused a general protection fault
in module GDI.EXE at 0014:000007b6.
Registers:
EAX=01010001 CS=0597 EIP=000007b6 EFLGS=00000246
EBX=00000000 SS=10b7 ESP=00008c00 EBP=00008c56
ECX=00000002 DS=7567 ESI=00000618 FS=0000
EDX=00000000 ES=10de EDI=00000ca0 GS=066f
Bytes at CS:EIP:
ab 85 c0 0f 84 98 00 89 7e d6 33 d2 8b c2 24 07 
Stack dump:
000007a2 00020000 0001066f 000000ff 000000cf 00010000 00080618 00010619 00000001
00000000 00200000 00010c98 000005cc 06181f21 10de0000 00000c9a 

Mozilla/Netscape exits. I can restart it with no problem and continue on, but
the crash happens every time I got to that URL or try to view yenc files.

Internet Explorer renders the URL just fine

Reproducible: Always
Steps to Reproduce:
1.Click on URL link or typing it in to brose site.
2.Mozilla clocks a bit then delivers the GPF message
3.

Actual Results:  
Mozilla exits. I can restart with no problem.

Expected Results:  
Displayed site URL is attached to.

GPF in GDI.EXE

Comment 1

15 years ago
No crash for me, although it took a while to load the page, and 100% CPU usage.
Maybe on a Win98 system (as the reporter seems to have) that will lead to a crash.

I use Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040408

Comment 2

15 years ago
WFM 2004041310/trunk/W2K
Note: Page on URL is pretty large, about 2326 kB.

Gary: Could you provide TalkBack incident ID of your crash?
Keywords: crash
(Reporter)

Comment 3

15 years ago
(In reply to comment #2)
> WFM 2004041310/trunk/W2K
> Note: Page on URL is pretty large, about 2326 kB.
> Gary: Could you provide TalkBack incident ID of your crash?

Forgive my ignorance since I am new to Mozilla, but what is Talkback? Is that 
some kind of means of reporting problems?

Also, I upgraded to the 1.7b version of Mozilla in hopes it might take care of 
the problem and it does not, same thing happens.

Thanks!

Comment 4

15 years ago
Talkback is a component of Mozilla which, when installed, automatically comes up
after a Mozilla crash and asks you to send some data to Mozilla. You can supply,
but that is no must, your email address, and it would be fine, if you can supply
the url, where the crash happened, and a short description. You can look at the
collected data, if you select detail, and remove some of them, if you want to.
You then decide if you want to send the report, or not.
Talkback is started automatically at crash, but it doesn´t talkback
automatically, you are always in control.

To use Talkback:
- you must download a talkback-enabled build
- you must have selected talkback for install at install time
- you must enable it after a crash (it is then waiting in the task bar) 
- you can fill in some data, loook at the data collected.
- you must click at submit button to send the report, or cancel to not send.

When a report is send, the server sends back a talkback ID.
You can see this id, if you start talkback.exe in your mozilla/components
directory. You can do so, while mozilla is running, and give this number here in
a comment. 
Developers then can see in which parts of the program Mozilla was crashing.

http://talkback-public.mozilla.org/reports/Trunk/smart-analysis.win 
If a talkback ID is known, it can be analyzed there:
http://talkback-public.mozilla.org/talkback/fastfind.jsp

A talkback enabled build for windows contains a talkback.xpi about 380 kb sized,
a build without talkback also contains a talkback.xpi, but it is a 1 or 2 kb
sized dummy. So if you really want to know if talkback is installed, you got to
look into your Mozilla/Components directory, if you find talkback.exe, it is
installed, waiting for a crash. 

Your Mozilla, BuildID 20040224xx ( xx is 09, I guess), doesn´t have talkback.

The  1.7b-release BuildID 2004031616 should have talkback, but I don´t know, if
you did install it. Look into the components folder.


I didn´t see a crash:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040413
(Reporter)

Comment 5

15 years ago
(In reply to comment #4)
> Talkback is a component of Mozilla which, when installed, automatically comes up
> after a Mozilla crash and asks you to send some data to Mozilla. You can 

Thanks for taking time to explain. I turned on Talkback and went to the site
multiple times and crashed. Talkback did not come up after the crashes. I made
sure it was on and it is.

Comment 6

15 years ago
Gary: Look at the mozilla\components directory and delete file compreg.dat if
exists. Then retry crash.
(Reporter)

Comment 7

15 years ago
(In reply to comment #6)
> Gary: Look at the mozilla\components directory and delete file compreg.dat if
> exists. Then retry crash.

You may be onto something here. I deleted the file, tried the URl again and it
crashed. For giggles I tried the URl again. The page the URL pointed to actually
displayed all the text and most of the graphics before it crashed.

Comment 8

15 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Talkback is a component of Mozilla which, when installed, automatically comes up
> > after a Mozilla crash and asks you to send some data to Mozilla. You can 
> 
> Thanks for taking time to explain. I turned on Talkback and went to the site
> multiple times and crashed. Talkback did not come up after the crashes. I made
> sure it was on and it is.


I just looked at BuildID 20040224, and saw, that it doesn´t contain talkback.
Builds without talkback are having a dummy talkback file in their windows-xpi
folder, size about 1 kb. The real talkback is about 300 kb sized.

You can specify to install Talkback, even when it is not available.
The dummy file is included for this, to avoid an error message.
So you don´t know, if talkback is installed or not, as long as you don´t look
into your Mozilla/Components folder. There must be a talkback.exe, about 390 kb
size.

What BuildID were you using with your crashs in Comment 7?
You can see it in the title bar, or in Help->About Mozilla, or type about: into
the location bar, and copy and paste the result:

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040427


Please retry with a current nightly, would be nice if this problem could be
solved for 1.7, as 1.7 should be long-lived.
(Reporter)

Comment 9

15 years ago
(In reply to comment #8)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > Talkback is a component of Mozilla which, when installed, automatically
comes up
> > > after a Mozilla crash and asks you to send some data to Mozilla. You can 
> > 
> > Thanks for taking time to explain. I turned on Talkback and went to the site
> > multiple times and crashed. Talkback did not come up after the crashes. I made
> > sure it was on and it is.
> 
> 
> I just looked at BuildID 20040224, and saw, that it doesn´t contain talkback.
> Builds without talkback are having a dummy talkback file in their windows-xpi
> folder, size about 1 kb. The real talkback is about 300 kb sized.
> 
> You can specify to install Talkback, even when it is not available.
> The dummy file is included for this, to avoid an error message.
> So you don´t know, if talkback is installed or not, as long as you don´t look
> into your Mozilla/Components folder. There must be a talkback.exe, about 390 kb
> size.
> 
> What BuildID were you using with your crashs in Comment 7?
> You can see it in the title bar, or in Help->About Mozilla, or type about: into
> the location bar, and copy and paste the result:
> 
> Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040427
> 
> 
> Please retry with a current nightly, would be nice if this problem could be
> solved for 1.7, as 1.7 should be long-lived.

There is a talkback.exe at 392k in the components dir, which is what I used.

Here is the build I used in comment #7: Mozilla/5.0 (Windows; U; Win98; en-US;
rv:1.7b) Gecko/20040316.

Where can I pick up a current nightly?

Comment 10

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a) Gecko/20040503
one crash, several hangs.

Celeron 333, 96 MB RAM, 200 MB free on c: for cache, temp, 200 MB free on D: for
swap, mail, 20 MB free on e:

My comment #4 must have been on this computer, as i can see from the time it was
made. Today I wanted to investigate a bit further, so i started Javascript
console, LiveHTTPheaders, and looked at the DUN status bytecount, and Mozilla
froze after some time, and I got a crash after a message 90% of resources used,
when still clicking around, to no avail.

I then got a local copy of the page by using the view-source: protocol
view-source:http://leo.typepad.com/tlr/2004/04/end_of_line.html
did load the source, in a normal tinme for these 2 MB, and the I could save it
with File-> save as: Files,all I got one 2.371 KB sized end_of_line.html.

Loading the local copy worked fine, for some seconds, then I got the same stall.
I killed and restarted Mozilla, and retried with JS disabled, to no avail.
I the edited the file, removing a rdf link and data, to no avail.

The page is a one or two images at the start, and then text only, and tons of
links, more than 2 MB html.

Validator gives following messages:

http://validator.w3.org/
http://validator.w3.org/check?uri=http%3A%2F%2Fleo.typepad.com%2Ftlr%2F2004%2F04%2Fend_of_line.html

 Sorry, I am unable to validate this document because on lines 335, 369  it
contained one or more bytes that I cannot interpret as utf-8 (in other words,
the bytes found are not valid values in the specified Character Encoding).
Please check both the content of the file and the character encoding 
indication.

335: “The Screen Savers”
369: uNDëRBLØG

http://jigsaw.w3.org/css-validator/validator-uri.html
http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fleo.typepad.com%2Ftlr%2Fstyles.css&warning=1&profile=css2&usermedium=all

Errors
URI : http://leo.typepad.com/tlr/styles.css

    * Line: 0 Context : Leo added

      Parse Error - --> .content date { font-family: trebuchet MS,verdana,
arial; font-weight:bold; color: white; text-align: center; background-color:
#004080; } 


Leo´s error was using html comment tags:
<!-- leo added -->
instead of C-style CSS comment tags:
/* <!-- Leo added --> */



The RDF validated: http://leo.typepad.com/tlr/index.rdf
http://www.w3.org/RDF/Validator/


So either the sheer size of the file or the CSS errors bring mozilla to a hang.
I assume it´s the file size on a computer with scarce resources.

Comment 11

15 years ago
Created attachment 147593 [details]
website reduced from 2371kb to 31kb

I only removed tons of posts under 'trackback' and tons of comments, rest is
unchanged.

typical entries:
<p class="posted">Tracked on April 15, 2004 12:43 PM</p>
<p><a id="p47826"></a>
&raquo; <a href="http://www.blogofdoom.com/archives/000008.shtml">No more
Leo</a> from The Blog of Doom<br />
Leo has left TechTV, details can be found here at his blog. I first saw him
back in the day on MSNBC's The Site which would eventually give birth to ZDTV
and then of course TechTV. I've watched nearly every... <a
href="http://www.blogofdoom.com/archives/000008.shtml">[Read More]</a>
</p>


<a id="c846782"></a>
<p>You will be very much missed. ............
<p>Yvonne </p>
<p class="posted">Posted by: <a
href="&#109;&#97;&#105;&#108;&#116;&#111;&#58;&#118;&#111;&#110;&#109;&#97;&#114;&#105;&#101;&#64;&#109;&#97;&#99;&#46;&#99;&#111;&#109;">Yvonne</a>
at April  2, 2004 04:22 PM</p>
<hr>

Comment 12

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a) Gecko/20040503
on another PC, Win98SE, 512MB, Atlon XP1600+

http://leo.typepad.com/snowtv.gif is a very fast gif.

The comments I cut from the testcase all were class posted,

and from the style sheet it uses font-size 75%, seems to be a lot of calculating.

.content p.posted {
	color: #004080;
	font-family: Trebuchet MS, Verdana, Arial sans-serif;
	font-size: 75%;
	font-weight:bold;
                text-align: center;
	
	line-height: normal;
	padding: 3px;
	}

Comment 13

15 years ago
Gary Braswell: Are you able to reproduce with Mozilla 1.7.x?
(Reporter)

Comment 14

15 years ago
(In reply to comment #13)
> Gary Braswell: Are you able to reproduce with Mozilla 1.7.x?

Yes, it unfortunately does the same thing.

Comment 15

15 years ago
Gary: And could you provide TalkBack incident ID?
(Reporter)

Comment 16

14 years ago
(In reply to comment #15)
> Gary: And could you provide TalkBack incident ID?

I have Talkback turned on, but it does not show up after the crash.

Comment 17

14 years ago
Gary: shut down Mozilla, delete components/compreg.dat and restart. Maybe it
should help TalkBack to wake up =)

Comment 18

14 years ago
URL gives a 404, so this bug can´t be verified.

Feel free to reopen, if there is a new URL which shows this bug with a current
Mozilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
(Reporter)

Comment 19

14 years ago
I would like to reopen. I am getting the same error with the current version of
Mozilla when I go to this URL:

http://www.yojoe.com/magazine/04/0923sponsornews.shtml
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 20

14 years ago
(In reply to comment #19)
> I would like to reopen. I am getting the same error with the current version of
> Mozilla when I go to this URL:
> 
> http://www.yojoe.com/magazine/04/0923sponsornews.shtml


wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041205

Which current version of mozilla are you using?
See Help->About Mozilla or type about: into the location bar.
(Reporter)

Comment 21

14 years ago
(In reply to comment #20)
> (In reply to comment #19)
> > I would like to reopen. I am getting the same error with the current version of
> > Mozilla when I go to this URL:
> > 
> > http://www.yojoe.com/magazine/04/0923sponsornews.shtml
> 
> 
> wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041205
> 
> Which current version of mozilla are you using?
> See Help->About Mozilla or type about: into the location bar.
> 

1.7.3

Comment 22

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040910

Leo was a very big HTML-file, this one is small, so I don´t know why you want to
file it here in this bug, I don´t see similarities.
Besides the website works for me both on 1.7.3 release and current trunk nightly.

Do you have extensions installed? Can you retry with a new profile just created
for testing, no extensions installed, not configured?
As you don´t have your bookmarks in the new profile, copy the URL, then go
Tools->Switch profile, create a new one, select and start it, and check the URL.
Please tell me the exact BuildID of the Mozilla you are using, you can copy it
from Help->about Mozilla, as I did above.

Maybe you´ve got a nightly some weeks older which is crashing there?
Are you using the release version, same as above, or a localized version?



website doesn´t validate, there is an invalid character in a line, rendered as
question mark, see line below 'Press Releases'

2nd Prints on the Market!  Devil&#65533;s Due Sells Out!

http://validator.w3.org/check?uri=http%3A%2F%2Fwww.yojoe.com%2Fmagazine%2F04%2F0923sponsornews.shtml
Message from validator:
 Sorry, I am unable to validate this document because on line 114  it contained
one or more bytes that I cannot interpret as utf-8 (in other words, the bytes
found are not valid values in the specified Character Encoding). Please check
both the content of the file and the character encoding indication.

Comment 23

14 years ago
URL above is now 404 as Leo has moved his blog.  The new location is here:
http://leoville.com/blog/index.php/TLR/comments/end_of_line/

Please edit the bug to reflect this change.

I did not crash on the page (the new location, that is).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050223
Firefox/1.0.1

What yEnc encoding (Which I'd like to see in Thunderbird/Mozilla Mail) has to do
with Leo Laporte's blog is beyond me.

Comment 24

14 years ago
I´m resolving this bug as worksforme, as I didn´t see crashes checked today
using Win98 and Win98SE, Mozilla 1.7a and 1.7b and current trunk nightly.
Site has moved and looks (very) slightly different.
Maybe I don´t crash because the old win98 computer has now 128MB instead of 96MB
of RAM.
Anyway, if you look around at that page, you can find stats that 34% of visitors
in February are using Firefox, so this bug would have lots of comments, if they
were crashing...

Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.