In <nsStyleStruct.cpp>, [Unused variable `nsIFrame*parentFrame']

RESOLVED FIXED in mozilla1.8alpha1

Status

()

Core
Layout: Misc Code
--
trivial
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

Trunk
mozilla1.8alpha1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Assignee)

Description

14 years ago
From "Blamed Build Warnings / Linux brad Clobber":
{{
roc+

1.	content/shared/src/nsStyleStruct.cpp:74 (See build log excerpt)
	Unused variable `nsIFrame*parentFrame'

72 {
73   nscoord result = 0;
74   nsIFrame* parentFrame = aFrame->GetParent();
75 
76   switch (aCoord.GetUnit()) {
}}
(Assignee)

Comment 1

14 years ago
*** Bug 240563 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Blocks: 228780
No longer blocks: 126457
(Assignee)

Comment 2

14 years ago
Created attachment 146151 [details] [diff] [review]
(Av1) <nsStyleStruct.cpp>
[Checked in: Comment 5]

Removing line 74:
{{
  74 roc+     3.54   nsIFrame* parentFrame = aFrame->GetParent();

  84 roc+     3.54	   nsIFrame* frame = aFrame->GetParent();
}}
Line 84 should be enough :->
Assignee: nobody → gautheri
Status: NEW → ASSIGNED
(Assignee)

Comment 3

14 years ago
Comment on attachment 146151 [details] [diff] [review]
(Av1) <nsStyleStruct.cpp>
[Checked in: Comment 5]


I have no compiler: Could you compile/test/review this patch ? Thanks.
Attachment #146151 - Flags: review?(daniel)
Comment on attachment 146151 [details] [diff] [review]
(Av1) <nsStyleStruct.cpp>
[Checked in: Comment 5]

Absolutely!
r=daniel@glazman.org
Attachment #146151 - Flags: review?(daniel) → review+
(Assignee)

Updated

14 years ago
Attachment #146151 - Flags: superreview?(roc)
Attachment #146151 - Flags: superreview?(roc) → superreview+

Comment 5

14 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Updated

14 years ago
Attachment #146151 - Attachment description: (Av1) <nsStyleStruct.cpp> → (Av1) <nsStyleStruct.cpp> [Checked in: Comment 5]
Attachment #146151 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Target Milestone: --- → mozilla1.8alpha
You need to log in before you can comment on or make changes to this bug.