If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Default font size should be set according to display size

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: Jari Aalto, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040405 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040405 Firefox/0.8

The default font size 16pt is way too big for laptop/notebook with regular
1024 screen size. Since the browser has access tot he physical screen resolution
values (from X), it could adjust the default value according to display resolutions.

For 1024 laptop, a better default font size is 12pt in menu:
Tools => Options => General => Fonts & colors => size pixels

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Assignee: bross2 → nobody
QA Contact: general
Summary: Default font size should be set accirding to display (LAPTOP ~ 12 pt) → Default font size should be set according to display size
Valid RFE, confirming. CCing mconnor.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 469306
Not a long ago the default font-size and dpi was fixed as part of CSS 3 (I think?), so this is not something we can do at the web. There are various new features that helps with this problem, like viewport sizing, units based on the device width, etc.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.