incorrect HTML parsing on html-comments (like <!--)

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
14 years ago
10 years ago

People

(Reporter: Delfins, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

if you have any HTML comments ( <!-- ..whatever.. --> ), and also having string
"--" inside, HTML is parsed incorrectly - we can see comment ending string "-->"
in our page.

Reproducible: Always
Steps to Reproduce:
1. create some HTML like

[html]
<strong> -- </strong>
[html]

2. comment it with <!-- and -->

3. see results

Actual Results:  
we can see printed string "-->" 

Expected Results:  
but it should not been there !!!
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

14 years ago
Status: RESOLVED → VERIFIED

Comment 1

14 years ago
the -- sequence is not allowed in HTML comments per the specification

Updated

10 years ago
Duplicate of this bug: 404687
You need to log in before you can comment on or make changes to this bug.