Composer mnemonics are placing letters in the message

VERIFIED FIXED in M14

Status

MailNews Core
Composition
P4
major
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Ninoschka Baca, Assigned: David Hyatt)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
Build 2000011211M13: NT4
Build 2000011212M13: Linux 6.0

Overview: Use any of the mnemonics in a Composer message and the action is
performed but it also places the character in the message.

Steps to reproduce:
1. In the 3-pane select the New Message button.
2. Click on the View menu
3. Type "t" to access the Toolbar item. Notice that a "t" appears in the
message.
4. Type "m" to "Show Message Toolbar". Notice that a "m" appears in the message.

Actual Results: Everytime a mnemonic is selected then the correct action occurs
but it also places the letter typed into the Address, Subject or body of the
message depending on where the cursor is active.

This problem makes it difficult to check the mnemonics under the Format menu! If
a word is highlighted and I use a mnemonic to change its attribute, such as
bold, then the word highlighted is deleted and is replaced with the letter "b".
Data loss.

Expected Results: Using a mnemonic should just perform the action, not type
extra characters.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → nbaca
Accepting
Status: NEW → ASSIGNED
Target Milestone: M14

Comment 2

18 years ago
Nominate as beta1 stopper
Keywords: beta1

Comment 3

18 years ago
PDT+
Whiteboard: [PDT+]
It's a generic problem with menu, nothing to do in particular with message 
compose. Reassign to trudelle
Assignee: ducarroz → trudelle
Status: ASSIGNED → NEW

Comment 5

18 years ago
reassigning to saari
Assignee: trudelle → saari

Comment 6

18 years ago
Oh Hyatt... this smells like the switch over to a bubbler instead of capturer for 
the keyboard accelerators.
Assignee: saari → hyatt
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 7

18 years ago
Setting priority to P4, relative to hyatt's other open PDT+ bugs
Priority: P3 → P4
(Reporter)

Comment 8

18 years ago
Disabling Composer menu items that are not working is covered with Bug# 25137. 
If this problem is unlikely to be fixed for beta1 then a workaround is to 
disable the mnemonics. Is this what should be recommended in bug# 25137?
(Assignee)

Comment 9

18 years ago
Fix checked in.  Mnemonics should now eat an event so thoroughly that not even 
God can see it.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

18 years ago
Build 2000-02-14-16M14: NT4
Verified Fixed. Great!
Note: Since mnemonics have been removed on Linux for Beta1, this is not an issue 
on Linux. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.