Proxy settings only allow internal or external sites, not both.

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: d, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316

If I use proxy settings, Mozilla will allow me to connect to sites beyond the
proxy server, but not internal sites. If I use a direct connection, I can
connect to internal site, but not those beyond the proxy server. It seems the
proxy options only allow for one option or another, and do not assume both
options are a requirement.

Reproducible: Always
Steps to Reproduce:
1. Update manual proxy configuration with required settings
2. Connect to internal site - Bad Gateway.
3. Connect to external site - OK
4. Change Proxy to direct connection to internet.
5. Connect to internal site - OK
6. Connect to external site - Mozilla.org cnnot be found, chcek name and try again.

2.
3.

Actual Results:  
Results as described above

Expected Results:  
Web page loaded.

The issue prevents me being able to use Mozilla as my default browser, if at all.
The basic problem is that your proxy doesn't know about your internal sites...
and there's nothing Mozilla can do about it, since it also doesn't know that
those sites happen to be internal.  The way to do this is to set up a proxy and
put the "internal site" domain in the "no proxy for" line below.  That's why
it's there.
Product: Browser → Seamonkey
-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.