Closed Bug 240738 Opened 20 years ago Closed 20 years ago

Uninstall not present

Categories

(SeaMonkey :: Build Config, defect)

Other Branch
x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.7final

People

(Reporter: tracy, Assigned: leaf)

Details

seen on Windows XP 2004-04-16-03-1.7

-Install the build, launch, use it, then quit the app.
-Attempt to uninstall the build from windows control panel
      Mozilla is not present on the list
-look in C:\Program Files\mozilla.org\Mozilla\uninstall
      It is empty.

results:
can't uninstall

expected results:
mozilla should be in the list in control panal of available programs to uninstall.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.7beta
I can reproduce this with the latest 1.7 windows build. Marking fixed. If this
is still happening for you, reopen.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Target Milestone: mozilla1.7beta → mozilla1.7final
verified with a build from 4/22
Status: RESOLVED → VERIFIED
(In reply to comment #1)
> I can reproduce this with the latest 1.7 windows build. Marking fixed.

Did you meant 'can't' !?


[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040421] (<-- 1.7rc1 !)
(W98SE)

First milestone showing this bug on my computer: v1.7rc1 :-(

Reopening: I'm not sure what comment 2 meant.
Status: VERIFIED → REOPENED
Flags: blocking1.7?
Resolution: WORKSFORME → ---
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040421] (<-- 1.7rc1 !)
(W98SE)

Note that my v1.7rc1 has bug 231190 (again) too :-(
This seems to be related to bug 241306:

I looked at the registry, and v1.7rc1 seems to have overwritten v1.7b
(uninstall) settings
...
I'm 99% sure because I tried to run the uninstall manually:

I thought it would remove v1.7b;
and it actually removed v1.7rc1 :-(

Now, I'm left with a v1.7b with no mean to uninstall (automatically) :-<
(I'll see what I can do about it...)
Depends on: 241306
Serge, sorry, yes, i meant i *can't* reproduce this with current builds.

Can you, perhaps with a 1.8rc2 build?
ugh. I meant 1.7rc2.
Worksforme with latest 1.7 branch build.
Flags: blocking1.7? → blocking1.7-
(In reply to comment #6)
> Serge, sorry, yes, i meant i *can't* reproduce this with current builds.
> 
> Can you, perhaps with a 1.[7]rc2 build?

Based on comment 5,
I'm waiting for v1.7rc3 to verify that it overwrites (or not) v1.7rc2 uninstall
registry: both being identified as 'v1.7'...

I'm not using nightlies:
if someone else wants to check sooner: steps should be to install a recent
nightly in another directory while having v1.7rc2 (or another recent nightly)
already installed.


(In reply to comment #8)
> Worksforme with latest 1.7 branch build.

This could be a "developer/tester" case only: "pure end-users" using two final
releases being identified by different release numbers would never see this bug.


"GRE core" is fully identified: with full build "date"
{{
[HKEY_LOCAL_MACHINE\Software\mozilla.org\GRE\1.7_2004051408]
}}

Whereas "Mozilla app" is partially identified: release number only
{{
[HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\1.7 (en)]

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Mozilla
(1.7)]
"DisplayName"="Mozilla (1.7)"
"UninstallString"="X:\\WINDOWS\\MozillaUninstall.exe /ua \"1.7 (en)\""
}}
> (In reply to comment #1)
> Reopening: I'm not sure what comment 2 meant.

Resolving Fixed, again.


(In reply to comment #9)
> I'm waiting for v1.7rc3 to verify that it overwrites (or not) v1.7rc2 uninstall
> registry: both being identified as 'v1.7'...

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040421] (<-- 1.7rc1 !)
(W98SE)

Installed v1.7b "over remains of previous instal."...
Uninstalled it; Cleaned up.
Installed v1.7rc1:
'Browser Only', then I can't check 'A.B.P.S.';
but 'Uninstal' feature is present :-)

The issue was definately the naming convention: v1.7rc1 identified as v1.7b !

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Mozilla
(1.7b)
HKEY_LOCAL_MACHINE\Software\Mozilla\Mozilla 1.7b
HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\1.7b (en)(In reply to comment #3)

I'll file another bug on this.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
No longer depends on: 241306
Resolution: --- → FIXED
(In reply to comment #10)
> I'll file another bug on this.

That's bug 64109 !
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.