2 pane window view without folder pane

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Mark Stier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

The message window should have different views selectable by the user. Eg. press
F9 for list of messages in current folder. At the top of that list could be a
drop-down list of message folders. Would be REALLY neat.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
(In reply to comment #0)
> F9 for list of messages in current folder.

Just like the sidebar in the browser window.

Comment 2

14 years ago
In Mozilla Mail F9 toggles the folder pane, and F8 toggles the message pane.
Also check Thunderbird, where you can choose from three types of views: classic,
wide view, and vertical view. 
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> In Mozilla Mail F9 toggles the folder pane, and F8 toggles the message pane.

Yes. But the message list is always above the message text. Would be nice to
have it to the left, too. Preferably in the message window because there one
usually wants to switch between messages residing in the same folder (inbox).
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

13 years ago
great for users who deal with many messages in a single folder.
no folder pane - use drop down select found in "search messages"?

rough mock ups attached - proportions not accurate by any means.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: RFE: message window views → 2 pane window view without folder pane

Comment 6

13 years ago
Created attachment 197542 [details]
2 pane view - message list and message preview

Comment 7

13 years ago
Created attachment 197543 [details]
2 pane view - with folder select drop down

Comment 8

13 years ago
Now that bug 21344 is fixed, and given the fact that you can hide the folder
pane by clicking the grippy, this is actually WFM now...
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 9

13 years ago
(In reply to comment #8)
> Now that bug 21344 is fixed, and given the fact that you can hide the folder
> pane by clicking the grippy, this is actually WFM now...

So it is! Nice!  Maybe I'll come back to using SM as my mail app.

View > Layout, Vertical view and then click the grippy
Then to select a new folder, either F9 or Go, ...
You need to log in before you can comment on or make changes to this bug.