Make "Find in this Page" start from the beginning of the document (as a default).

RESOLVED WONTFIX

Status

()

Firefox
General
--
enhancement
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: Kevin Ar18, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040407 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040407 Firefox/0.8.0+

Currently, "Find in this Page" starts searching wherever the user has clicked
their mouse.  I propose changing "Find in this Page" so that is starts searching
at the beginning of the document, and, if necessary, make searching where the
user clicks an option in the dialog.

1) If a user is looking to find something on the page, which he often is, then
by not starting at the beginning, the user does not know if the search has
covered the entire page.  Instead, he must first scroll to the top, click on the
top of the page, and then do the search to be sure everything is covered.  Or,
he must search one time using down, and then click the up radio option and
search a second time to be 100% sure the entire page has been covered.  This
process makes something very simple, much more tedious than it needs to be.
2) The "Find in this Page" does not indicate that the search begins where the
user clicks the mouse.  Most people migrating from IE (which is the majority of
people) will expect it to search the entire page, and may be oblivious for some
time to the fact that their searches are not doing what they want.

Solution 1:
Switch back to the method where it begins searching at the top of the page. 
Find as you type could then be used to begin searching at a certain point.  The
only downside to this, is that people might not like find as you type and/or
there may be instances where find as you type doesn't fit what the user needs.

Solution 2:
Switch back to the method where it begins searching at the top of the page, and
make this the default.  However, include an option to "begin searching where the
user clicked."  The only downside to this is the UI clutter it could cause if,
and when, Bug 234048 is implemented.

Other solutions?
If we need to collect some user feedback on this issue, I think we could take
some time to do that as well.  However, I do feel that this is a significant
issue (especially for people migrating to Firefox) that needs to be addressed in
some way.

Note, I will attach some screenshots....

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 146354 [details]
Examples of the dialog with the checkbox option.

These are two screenshots of the "Find in This Page" dialog with a checkbox
option entitled:
"Begin search where I click the mouse."
The first dialog is based on the current design.  The second dialog is what it
would look like if, and when, Bug 234048 is implemented.

Basic points about the feature:
1) The checkbox would be unchecked by default.
2) I worded the checkbox "Begin search where I click the mouse" instead of
"Begin searching at the top of the page."  If I had chosen to use "Begin
searching at the top of the page" as a checkbox option, then a number of people
would not have known what happened when it was unchecked.
1) wrap search is on by default, so having to search twice is untrue, if nothing
is found before the end of the page, the search wraps around and searches from
the top.  So that's your first assertion tossed out the window.

2) IE's default represents a usability loss since it forces a user to start from
the top each time.  If you are going through a long document, each time you want
to skip to the next mention of your search term you have to click/hit enter n+1
times to get to the next result.  So if a term is mentioned 20 times in a long
document, using the dialog to find the 19th entry if  you're at the 18th
requires hitting Find 19 times instead of once.  If focus is at #18, and you
choose to search down, finding a result at #1 may lead to the mistaken
impression that there is nothing after #18.

If you want to search from the beginning, scroll to the top and search, that's
the logical behaviour.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.