Closed Bug 240823 Opened 17 years ago Closed 17 years ago

Installer does not promt to import data

Categories

(Firefox :: Installer, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 240136

People

(Reporter: sgupta, Assigned: bugs)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040417 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040417 Firefox/0.8.0+

After this nightly build is downloaded and installed, the Import Wizard
initiates and starts importing the favorites, saved passwords, history etc. 
The user is not provided any control over he import data. The Back and Cancel 
buttons are disabled and so the user cannot cancel the import.


Reproducible: Always
Steps to Reproduce:
1.Download the latest nightly build from mozilla.org and start installation.
2.When the installation is finished, check off "Launch Firefox" and click "Finish"
3.Manually launch the browser

Actual Results:  
After the browser is installed, the Import Wizard automatically starts importing
the favorites, cookies etc from the installed browsers on he system. The user
has no control of stopping this import of data.
Also when the import is complete, the next dialog box disappears in a couple of
seconds not allowing the user to even manually click the "Finish" button.


Expected Results:  
The installer should ask for user input whether to import data from other
browsers, rather than taking over the control.

Follow up tests
---------------
1. Replicated three times and the same misbehavior is seen. The last window,
signalling the finish of import, disappears in a few seconds, making it almost
worthless to have it displayed in the first place.


Importance of the Bug
---------------------
1. The installer takes control of importing the data from other browsers,
whereas the user might not want certain data to be imported to this browser.

2. Also the buttons provided in the Import Wizard are disabled, so even if the
user changed his mind mid way of the import, he cannot diable the import.

*** This bug has been marked as a duplicate of 240136 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.