Camino crashes when it encounters certain file type that requires a helper application [@ __dynamic_cast]

RESOLVED DUPLICATE of bug 240748

Status

Camino Graveyard
Downloading
P1
blocker
RESOLVED DUPLICATE of bug 240748
14 years ago
14 years ago

People

(Reporter: Chris Petersen, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({crash, regression})

unspecified
Camino0.8
PowerPC
Mac OS X
crash, regression

Details

(crash signature)

(Reporter)

Description

14 years ago
Build: 2004041408 NB
Platform: OS X 10.3.3
Expected Results: Camino should been download the file
What I got: Camino crashs when it encounters the file
0x001e7ea8 nsOSHelperAppService::GetMIMEInfoFromOS

Steps to reproduce:

1) Launch Camino
2) Go to the following url that points to a word .doc file
http://www.stopesso.com/campaign/Pentagon.doc
3) Camino crashes

This is a regression that started with the 2004041408 NB since it works
correctly with the previous version of 2004041208 NB.
(Reporter)

Comment 1

14 years ago
This problem doesn't happen with either the Macho Mozilla nightly build
(2004041708) or Mac Firebird (20040417).
Priority: -- → P1
Target Milestone: --- → Camino0.8
(Reporter)

Comment 2

14 years ago
Here is the stack trace I get from gdb:

(gdb) bt
#0  0x00694de4 in __dynamic_cast ()
#1  0x001e7ea8 in nsOSHelperAppService::GetMIMEInfoFromOS(nsACString const&,
nsACString const&, int*) ()
#2  0x001f22b4 in nsExternalHelperAppService::GetFromTypeAndExtension(nsACString
const&, nsACString const&, nsIMIMEInfo**) ()
#3  0x001e7bb4 in nsOSHelperAppService::GetFromTypeAndExtension(nsACString
const&, nsACString const&, nsIMIMEInfo**) ()
#4  0x001ed3fc in nsExternalHelperAppService::DoContent(nsACString const&,
nsIRequest*, nsISupports*, nsIStreamListener**) ()
#5  0x001e086c in nsDocumentOpenInfo::DispatchContent(nsIRequest*, nsISupports*) ()
#6  0x001dfe84 in nsDocumentOpenInfo::OnStartRequest(nsIRequest*, nsISupports*) ()
#7  0x000ba590 in nsHttpChannel::CallOnStartRequest() ()
#8  0x000baba0 in nsHttpChannel::ProcessNormal() ()
#9  0x000ba860 in nsHttpChannel::ProcessResponse() ()
#10 0x0009ebec in nsInputStreamPump::OnStateStart() ()
#11 0x0009eb00 in nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) ()
#12 0xefd34104 in nsInputStreamReadyEvent::EventHandler(PLEvent*) ()
#13 0xefcf64ec in PL_HandleEvent ()
#14 0xefcf6410 in PL_ProcessPendingEvents ()
#15 0xefcf79f4 in nsEventQueueImpl::ProcessPendingEvents() ()
#16 0x005ae4ac in -[EventQueueHandler eventTimer:] ()
#17 0x909f389c in __NSFireTimer ()
#18 0x901946d8 in __CFRunLoopDoTimer ()
#19 0x90191a38 in __CFRunLoopRun ()
#20 0x90195f4c in CFRunLoopRunSpecific ()
#21 0x927d648c in RunCurrentEventLoopInMode ()
#22 0x927dcb6c in ReceiveNextEventCommon ()
#23 0x927feccc in BlockUntilNextEventMatchingListInMode ()
#24 0x92dd2a34 in _DPSNextEvent ()
#25 0x92de93b0 in -[NSApplication
nextEventMatchingMask:untilDate:inMode:dequeue:] ()
#26 0x92dfd718 in -[NSApplication run] ()
#27 0x92eb9b80 in NSApplicationMain ()
#28 0x0000a308 in _start ()
#29 0x0000a188 in start ()
(Reporter)

Updated

14 years ago
Keywords: regression
(Reporter)

Updated

14 years ago
Summary: Camino crashes when it encounters a file type that requires a helper application → Camino crashes when it encounters certain file type that requires a helper application

Comment 3

14 years ago
Crash was already resolved by backing out bug 235832.

*** This bug has been marked as a duplicate of 240748 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Summary: Camino crashes when it encounters certain file type that requires a helper application → Camino crashes when it encounters certain file type that requires a helper application [@ __dynamic_cast]
Crash Signature: [@ __dynamic_cast]
You need to log in before you can comment on or make changes to this bug.