res: vs. resource:, retire obsolete res: protocol

VERIFIED FIXED

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
19 years ago
16 years ago

People

(Reporter: Chris McAfee, Assigned: dougt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
res: vs. resource:, warren says:

The one under protocol/res is the new one, and is now registered under
the scheme "resource:". We've been using that for a few months now. The
old one (protocol/resource) is "res:" and is obsolete.
Heinous source directory naming confusion -- should leaf and I (leaf more than
I) fix this when netwerk is renamed to network?

/be

Updated

19 years ago
Assignee: warren → leaf

Comment 2

19 years ago
Sure. Rename netwerk to network, and netwerk/protocol/res to
network/protocol/resource. Throw out netwerk/protocol/resource.

Comment 3

19 years ago
will we loose CVS history in the process?
(Reporter)

Comment 4

19 years ago
I think we can just rename the directory in the repository
and maintain all cvs histories.

Comment 5

19 years ago
*** Bug 13310 has been marked as a duplicate of this bug. ***
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Comment 7

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc

Comment 8

17 years ago
At least the resource directory (with the res protocol!) is gone from the pull,
no longer part of SeamonkeyAll. I think this bug can be marked fixed unless you
still want to do the renaming actions.

Comment 9

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 10

16 years ago
bug cleanup - all leaf's bugzilla bugs should be assigned to leaf@mozilla.org
(not leaf@netscape.com), now and any future bugs created.

this should be a one time change, apologies for the spam.
Assignee: leaf → leaf
Status: ASSIGNED → NEW

Comment 11

16 years ago
Can someone either:

fix this,
retarget this,
future this?

I've been asked to clean up all my Mozilla 1.0 and later bugs. being unfixed,
and milestoned to 1.0.1 puts it in limbo.

Comment 12

16 years ago
untargeted, set to defaults +clean-report. needed for cleanup of Networking QA
summary.

If this isn't supported, I don't want to have to write an extra test suite for it.
Assignee: leaf → dougt
Keywords: clean-report
Target Milestone: mozilla1.0.1 → ---
(Assignee)

Comment 13

16 years ago
resource: is gone.  i think we should just leave the spelling of "netwerk" alone.  

marking fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
VERIFIED: w/ lxr:
http://lxr.mozilla.org/mozilla/source/netwerk/protocol/ (no resource directory)

You mean the "resource" directory right, not the "resource:" protocol scheme is
gone right?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.