Auto download does not check if location its downloading to actually exists

RESOLVED DUPLICATE of bug 270557

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 270557
14 years ago
10 years ago

People

(Reporter: Diego Mathis, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I have removed a Harddisk e.g. E:\, Firefox was configurated to download to the
folder "e:\downloads".
Now when I downloaded something, it says me that a failure happened..



Reproducible: Always
Steps to Reproduce:
1. Configurate Firefox to have the targetdownloadfolder as d:\downloads
2. change the drive letter, of your HD "d:\" to something else
3. restart your Windows
4. then try to download something to the default folder "Save to disk"

That should work... I removed a HD, this removed the drive "e:\", if the above
steps, don't give that result @#§ç¦¦, then try instead of first 3 steps, to
1. shut down
2. remove a HD
3. start windows
4. then try to download something to the default folder "Save to disk"
Actual Results:  
A Msgbox poped up, with the Information that it has Failed due to some
problem(unspecified!), retry the download..(It is not possible for me to
reproduce the problem now,(I would have to restart, and the to rewrite this,:D)) 

Expected Results:  
This is not a really a bug(since it has only, to be implemented :D ), but would
be nice if checks before saving if that place exists, and if not, then ask where
to save.. And ask if that should be the new default place to save at.

Comment 1

14 years ago
When I tried it, it told me there was an error saving the file and I should try
saving it somewhere else instead. Reporter is right, it should check that the
location exists before starting the download.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: changed driveletters, then downloaded(targetfolder was on that HD), it shows as failure, had to redownload → Auto download does not check if location its downloading to actually exists

*** This bug has been marked as a duplicate of 270557 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.