Download progress dialog doesn't update the buttons when complete (100% of Saved)

RESOLVED FIXED

Status

SeaMonkey
Download & File Handling
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

Trunk
PowerPC
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8a) Gecko/20040417
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8a) Gecko/20040417

Note concerning my configuration: In the Downloads preferences, I've chosen
"Open a progress dialog", and "Keep this window open after the download is
complete" is unchecked in any progress dialog.

When I shift-click on any link, the download occurs normally until it completes
(the window title of the progress dialog showing "100% of Saved"). At this
point, the buttons state remains as before: Cancel and Pause are shown and are
still active. It is impossible to close the progress dialog window except via
the window manager (in particular, clicking on the Cancel button has no effect).

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla.
2. Open some page having links.
3. Shift-click on a link (I've tried different servers, including the Google URL
above).
Actual Results:  
When the download is complete, the progress dialog shows active Cancel and Pause
buttons.

Expected Results:  
The Cancel button should be replaced by a Close button as before.

This seems to be a new bug (it didn't occur in a 1.7b snapshot I compiled 3
weeks ago). I don't know if there's any particular relation with bug 232169.
I think you're hitting some temporary bustage that is now fixed... update to
today's tree and retest?
(Reporter)

Comment 2

14 years ago
With Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8a) Gecko/20040420 compiled
last night, this is even worse. In addition to the Saved dialog, I sometimes get
an alert box (with a ! in a triangle) showing the website name (only the host
part). After clicking on OK, both the alert box and the Saved dialog disappears.
When there is no alert box, the Saved dialog disappears (well, this is normal,
but I now remember that I had "Keep this window open after the download is
complete" checked previously -- well, I don't remember exactly if it was checked
ot if there was a bug, but at least I had to click on the Close button, and I
prefered this way, and it seems no longer possible to change that).

Comment 3

14 years ago
(In reply to comment #2)
> With Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8a) Gecko/20040420 compiled
> last night, this is even worse. In addition to the Saved dialog, I sometimes get
> an alert box (with a ! in a triangle) showing the website name (only the host
> part). After clicking on OK, both the alert box and the Saved dialog disappears.
That is Bug 240367.
Product: Browser → Seamonkey

Comment 4

13 years ago
Vincent: it looks like this was transient bustage that was fixed in other bugs.
 Are you still seeing this?
(Reporter)

Comment 5

13 years ago
No, the problem disappeared at the same time as bug 240367. So, I'm closing the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.