folderpane context menu shows all entries on every position

VERIFIED FIXED in Thunderbird0.7

Status

Thunderbird
Mail Window Front End
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: whimboo, Assigned: janv)

Tracking

({regression})

unspecified
Thunderbird0.7
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

fix
973 bytes, patch
Scott MacGregor
: review+
Scott MacGregor
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
Mozilla Thunderbird 0.6+ (20040419)

Opening context menu of folderpane shows all entries. Normally unused entries
are hidden. 

Following warning/error I get when opening menu:

  Warning: reference to undefined property folderTree.treeBoxObject.selection
  Source File: chrome://messenger/content/mailContextMenus.js
  Line: 242

  Error: folderTree.treeBoxObject.selection has no properties
  Source File: chrome://messenger/content/mailContextMenus.js
  Line: 242

Closing the menu raises in following warning/error:

  Warning: reference to undefined property treeBoxObj.selection
  Source File: chrome://messenger/content/mailContextMenus.js
  Line: 23

  Error: treeSelection has no properties
  Source File: chrome://messenger/content/mailContextMenus.js
  Line: 27

Comment 1

14 years ago
this looks like it was caused by the recent tree syntax landing of Jan's. Jan
can you take a look?
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.7
(Assignee)

Comment 2

14 years ago
Created attachment 146565 [details] [diff] [review]
fix
(Assignee)

Updated

14 years ago
Assignee: mscott → varga
(Assignee)

Comment 3

14 years ago
Comment on attachment 146565 [details] [diff] [review]
fix

I'm not sure why I forgot to update this code too
Attachment #146565 - Flags: superreview?(mscott)
Attachment #146565 - Flags: review?(mscott)

Comment 4

14 years ago
Comment on attachment 146565 [details] [diff] [review]
fix

thanks for looking into this Jan.
Attachment #146565 - Flags: superreview?(mscott)
Attachment #146565 - Flags: superreview+
Attachment #146565 - Flags: review?(mscott)
Attachment #146565 - Flags: review+
(Assignee)

Comment 5

14 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

14 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.