Enable mouse buttons 6 and 7 on Linux-builds.

RESOLVED DUPLICATE of bug 64485

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 64485
15 years ago
13 years ago

People

(Reporter: stian_web, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040405 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040405 Firefox/0.8

Windows builds have had support for all mousebuttons quite a while now. There
have long existed a patch for Linux, which have been incorporated in the
official Debian packages since Firebird 0.6 without problems, and have as such
got a lot of testing. The patch has lately been both reviewed and superreviewed
by bryner and roc respectively, and was committed to the trunk tonight.

It will be a pity to have both Firefox 0.9 and 1.0 without this feature, even
though I know it is late. Please consider to apply this patch from
http://bugzilla.mozilla.org/show_bug.cgi?id=64485

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
if this is going to be in Fx 0.9/1.0, it'd most likely have to land on the 1.7
branch (and thus require a1.7 on the patch in bug 64485).  I'm not currently
aware of any plans to branch from the branch, but I may be wrong on this, many
things aren't 100% clear.  However, I don't see any reason as of yet for that to
happen, after what happened with maintaining the 0.8 branch I don't think ben
wants to go that way.



QA Contact: mconnor
(Reporter)

Comment 2

15 years ago
Mike, that was what I thought, but bsmedberg told me to do it this way. I hope
he could provide us with some info on why and how...
(Reporter)

Comment 3

15 years ago
Closing this, since the patch was applied on the 1.7 branch :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 64485 ***
Resolution: FIXED → DUPLICATE
You need to log in before you can comment on or make changes to this bug.