Save All attachments from a draft message downloads the entire email for each attachment

RESOLVED DUPLICATE of bug 199632

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 199632
14 years ago
13 years ago

People

(Reporter: George Jenkins, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040415 Firefox/0.8
Build Identifier: Mozilla Thunderbird 0.5 (20040415)

When using "Save All" attachments for a message in my draft folder, Thunderbird
appears to fully download the message for each attachment that needs to be saved
(before saving the attachment). 

(Im using an IMAP server)

Reproducible: Always
Steps to Reproduce:
1. Select a message in my draft folder with several attachments (On IMAP server,
dunno about POP3)
2. Right-click on the attachments (displayed below the message) or select
File->Attachments->Save All.
3. Select a directory to download to

Actual Results:  
Thunderbird displays "Downloading Message" in status bar it seems for each
attachment. (takes a long time to download a PDF document (~200kb) and several c
sources (~5kb) on a dial-up modem.)

Expected Results:  
Downloaded the message once (or not at all depending on "Offline & Disk Space"
settings) and extracted the attachments.

System is P4 running Gentoo Linux and compiled Thunderbird from sources.

Comment 1

13 years ago
Bug 199632, which has been fixed in Seamonkey.  Testing with TB 0.7, it works OK 
for me.
George Jenkins, feel free to reopen if you feel I've closed this in error.

*** This bug has been marked as a duplicate of 199632 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.