formatting toolbar goes crazy when there is some error while delivering mail

VERIFIED FIXED in Thunderbird0.6

Status

VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: neeme, Assigned: mscott)

Tracking

unspecified
Thunderbird0.6
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla Thunderbird 0.5+ (20040413)

If either I cancel the delivery of an email or there some error occurs while
delivering an email, the formatting toolbar occupies half of the compose window
when the focus returns to the compose window, after the error/cancellation.

How to get back the normal size toolbar?
If you move your mouse over the toolbar, then at some mouseover of a button
event, the toolbar restores its original size.

But this happens occasionally, not always.
And this never happened with 0.5 release, started happening when I upgraded to a
nightly build.

Reproducible: Sometimes
Steps to Reproduce:
1. compose a new message
2. try to send it
3. either cancel the delivery or produce some error (unplug the net?)
4. press all the [ok] buttons to get back to compose window
Actual Results:  
when you get back to compose window, sometimes the toolbar goes crazy and fills
half of the compose window (I'll also attach a screenshot).

Expected Results:  
toolbar should stay with normal size.
(Reporter)

Comment 1

15 years ago
Created attachment 146580 [details]
screenshot

screenshot that shows the resulting toolbar
WFM Mozilla Thunderbird 0.6+ (20040419)

Do you have created a fresh profile and tested there?
(Assignee)

Comment 3

15 years ago
I can't reproduce this but I know the checkin changes that caused it. It had to
do with the CSS changes for the new smiley icons. 

I'll target this for 0.6 in the hopes that someone can figure out the mistake I
made and make this work. Otherwise it'll get bumped to 0.7

I'm not able to reproduce it myself. But I'm not doubting you. 
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird0.6
(Assignee)

Comment 5

15 years ago
Created attachment 146610 [details] [diff] [review]
the fix

this trys to solve the problem I was originally fixing in a better way that
doesn't caue this regression.
(Assignee)

Comment 6

15 years ago
fixed for .6 and on the trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Scott, the new icons are stored within one bitmap file with a height of 310px.
This is exact the same size of the miss-drawn formatting toolbar. How do you
handle "list-style-image: url("chrome://editor/skin/icons/btn2.gif");"? With CSS
you can't grab one icon out there. AFAIK every time the whole list-image is
drawn. But why the icons aren't visible on the attached screenshot?
(Reporter)

Comment 8

15 years ago
One more comment about when the toolbar restores the original size.
Originally I wrote:
"If you move your mouse over the toolbar, then at some mouseover of a button
event, the toolbar restores its original size."

The mouseover button in question is the smiley button (pulldown) that is not
really visible on the screenshot. So I guess you're right when you say that it
has to do with those new smileys. Why they are not visible... don't know.

But on opening a new compose window there seems to be the same effect, although
for a very short while: there is some "flickering" that seems like the toolbar
is very big in the beginning and then it is very quickly resized to the normal
height.
(Assignee)

Comment 9

15 years ago
re-opening. I have a better fix for this
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

15 years ago
Created attachment 146962 [details] [diff] [review]
better fix

this fix actually adds the smiley menu PNG's to the editor format bar. I made a
new image that replaces editor's btn2.gif with format-toolbar.png which
contains the new menu smileys in addition to the old artwork for the editor
toolbar.
(Assignee)

Comment 11

15 years ago
this better fix is now checked into the 0.6 branch, the 1.7 branch and the trunk.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

15 years ago
*** Bug 241805 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.