Aldo Shoes main page doesn't work in Mozilla

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English Other
RESOLVED WORKSFORME
14 years ago
3 years ago

People

(Reporter: Neil Marshall, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
When I go to aldo shoes web site I get this javascript error:

Error: canadaLang is not defined
Source File: http://www.aldoshoes.com/aldoshoes/
Line: 55

Comment 1

14 years ago
I see

Error: syntax error
Source File: http://www.aldoshoes.com/aldoshoes/_Static/javascript/dhtml.js
Line: 41, Column: 1
Source Code:
 = LA[x]

Note that LA is a NodeList not an element which means LA.id is undefined.  

function ns6_initlayers()
	{
	LA = document.getElementsByTagName("DIV");
	for(x=0;x<LA.length;x++)
		{
		eval(LA[x].id + " = LA[x]");
		LA[x].init = mapping_ns6;
		LA[x].init();
		}
	windowwidth = window.innerWidth;
	windowheight = window.innerHeight;
	return LA.length;
	}

Neil, please send in a complaint and reference this bug.
WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

14 years ago
Works for you?  How?  It's still firing off javascript errors for me with FF 0.9.2

Comment 4

14 years ago
LA is a NodeList but LA[x] is a DIV Element. The problem is they iterate over
all DIVs but not all have ID attributes. 

Error: syntax error
Source File: http://www.aldoshoes.com/aldoshoes/_Static/javascript/dhtml.js
Line: 41, Column: 1
Source Code:
 = LA[x]

This error is due to global exposure of elements with id's which we do not support.

Error: canadaLang is not defined
Source File: http://www.aldoshoes.com/aldoshoes/#
Line: 55

Error: canadaLang is not defined
Source File: http://www.aldoshoes.com/aldoshoes/#
Line: 63

=> REOPEN
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

12 years ago
This seems to be working now.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago12 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.