Hang when selecting mail messages with attachments

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: sjbufton, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7b/mozilla-i686-pc-linux-gnu-1.7b-installer.tar.gz

After installing 1.7b, certain mail messages are unreadable, and cause Mozilla
to hang (90%+ CPU for several minutes) reproducibly. The problem only happens
with messages with attachments, but not all of these. The hang may due to the
size of the attachment, or type. Other messages (before or after the message
causing the hang) are readable.
Reinstalling 1.6 (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040113) solves the problem, so it is new in 1.7b.

Reproducible: Always
Steps to Reproduce:
1. Select a mail message with an attachment

Actual Results:  
Status bar message 'Loading message...' appears, all Mozilla windows hang. The
message is not displayed, and other windows do not repaint when necessary. The
browser must be killed using KDE's task manager, or CTRL-C when started from the
command prompt.

Expected Results:  
Not hung :-)
(Reporter)

Comment 1

15 years ago
Created attachment 146604 [details]
Sample e-mail causing the hang

This e-mail hangs 1.7b, but can be viewed normally in 1.6

Comment 2

15 years ago
My build: 2004041917

Reporter, can you please download a newer build.  Your build is a bit old.  
(Reporter)

Updated

15 years ago
Attachment #146604 - Attachment is obsolete: true
(Reporter)

Comment 3

15 years ago
Tested with 1.7rc1, works.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 4

15 years ago
No bug/patch identified that fixed this.

->WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.