Closed Bug 241160 Opened 17 years ago Closed 16 years ago

Can't change to caret browsing mode, when focus on textbox

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 269306

People

(Reporter: ginnchen+exoracle, Assigned: nian.liu)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20040406
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20040406

When focus on textbox, can't change to caret browsing mode by using F7 or arrow key.

Reproducible: Always
Steps to Reproduce:
1.Go to http://bugzilla.mozilla.org/, press F7 to turn on caret browsing
2.Put the caret at the end of " Enter a bug # or some search terms:"
3.Press TAB, now you focus on the textbox, type "abcd".
4.Press F7 twice, press arrow key, you can't go back to caret browsing mode.
Actual Results:  
You can't go back to caret browsing mode.
Press TAB or Shift-TAB can continue caret browsing, but the focus changed to
next/prev link or button.

Expected Results:  
There should be a method to continue caret browsing from the textbox's position
after step 3.
Blocks: caretnav
I see this on LInux 2004052405
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 259424 has been marked as a duplicate of this bug. ***
Assignee: aaronleventhal → nian.liu
according to new proposal, F8/Ctrl+F8 will be used to move focus out of textbox
Attached patch patchSplinter Review
Attachment #159067 - Flags: review?(aaronleventhal)
Status: NEW → ASSIGNED
Blocks: 260668
Nian, I thought that F8 would move focus away from any form control to the
document. Why make it only specific to text boxes? (What happens in Opera, are
we doing something similar to that?)
according to our discussion, we decide to postpone the implementtation of form
control until we get a consistent option from community. so pls. give it a
review -. after new proposal comes, i'll fix it according to it.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #159067 - Flags: review?(aaronleventhal) → review-

*** This bug has been marked as a duplicate of 269306 ***
Status: REOPENED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.