Cookie Manager Options No Longer Independent

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Chris Culbertson, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040415 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040415 Firefox/0.8.0+

I hope this is a bug/oversight and not a new "feature."  In Firebird 0.7, cookie
acceptance criteria settings were independent of each other (i.e. any
combination of "Enable Cookies From Originating Website Only", "For This Session
Only", and "Ask Before Accepting" could be used).  In Firefox 0.8, "Enable
Cookies From Originating Website Only" is independent, but I must now choose
between "Accept For This Session Only" and "Ask Before Accepting."  I *ALWAYS*
have both of these last two options enabled when browsing with Firebird.  I now
have to choose between expanding my cookie whitelist and blacklist on-the-fly
and automatically modifying persistent cookies into session cookies.  IMHO, this
is a giant step backwards in user friendliness.  Does anyone else think so?

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
actually, current prompt dialogs give an explicit choice (Allow/Allow for 
Session/Block) with the ability to persist said settings.  As a result, 
combining the prefs is useless now since the prompt explicitly controls how the 
cookie is accepted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.