no keycode for scroll_lock

RESOLVED FIXED in mozilla1.8alpha1

Status

Core Graveyard
GFX: Gtk
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Tony Chang, Assigned: Christopher Aillon (sabbatical, not receiving bugmail))

Tracking

Trunk
mozilla1.8alpha1
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

When in Linux, the scroll_lock key does not generate a keycode, whereas in
Windows (2K), scroll_lock generates keycode of 0x145.  This was tested in
Firefox 0.8.  You can test it at the URL,
http://www.sonic.net/~tchang/keycode.html .

Reproducible: Always
Steps to Reproduce:
1. surf to http://www.sonic.net/~tchang/keycode.html using Windows Firefox 0.8,
and Linux Firefox 0.8.
2. Hit the Scroll_Lock button on the keyboard and note the different results.


Actual Results:  
in Linux, the keycode returned was 0x0

Expected Results:  
return keycode of 0x145

Comment 1

14 years ago
*** Bug 241252 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Don's see anything in FireFox (20040419) (no code at all), but do in Mozilla
20040419.
If it's platform specific, it's a widget issue, not a DOM one...

Confirming the problem with a current GTK1 build.
Assignee: events → blizzard
Status: UNCONFIRMED → NEW
Component: DOM: Events → GFX: Gtk
Ever confirmed: true
Created attachment 146724 [details] [diff] [review]
Fix

the num lock key was missing, too.
Assignee: blizzard → caillon
Status: NEW → ASSIGNED
Attachment #146724 - Flags: superreview?(blizzard)
Attachment #146724 - Flags: review?(blizzard)
> Actual Results:  
> in Linux, the keycode returned was 0x0
> 
> Expected Results:  
> return keycode of 0x145

Actually, your expected results are wrong.

scroll_lock should return a keycode of 0x91, not 0x145.  Converted to decimal,
0x91 is 145 which is presumably what you meant....
Attachment #146724 - Flags: superreview?(blizzard)
Attachment #146724 - Flags: superreview+
Attachment #146724 - Flags: review?(blizzard)
Attachment #146724 - Flags: review+
Fix checked in to trunk 2004-04-22 12:19 PDT.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8alpha
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.