[FONT MAC]Mac - Fonts rendered with jagged edges

RESOLVED WORKSFORME

Status

()

Core
Layout
P2
normal
RESOLVED WORKSFORME
19 years ago
18 years ago

People

(Reporter: glynn, Assigned: dcone (gone))

Tracking

({fonts, pp})

Trunk
PowerPC
Mac System 8.5
fonts, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Mac PPC Jan14 Seamonkey build
PBook G3, System 8.5

1.  Launch Seamonkey on PPC.
2.  Go to: default home page loaded or a page like http://www.cnn.com and look at
all fonts on page, in particular their edges.

•  Fonts are not rendering properly; jagged edges of the characters at what
appears to be all sizes. Simon <sfraser> seems to think the issue is in Atsui (?)
code for Intl.  Assigned to Simon for now for input then Simon please reassign as
needed.

Win32 Jan 14 build displays properly; fonts' edges on page are smooth..  Linux
build is too unstable to check against.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
Try the 1/15 build - so smooth! (because ATSUI was turned off). If ATSUI breaks
the system's font anti-aliasing, there is not much we can do. This bug should
fester until ATSUI goes back in.

Comment 2

19 years ago
glynn, please give results against latest build.
(Reporter)

Comment 3

19 years ago
Well fonts are smoother in Jan21 as Simon said :-)  but leaving bug open to
"fester" and assigned until real fix is developed

Updated

19 years ago
Assignee: sfraser → pierre
Status: ASSIGNED → NEW

Comment 4

19 years ago
This bug needs to be revisited one ATSUI goes back in. I'm off PP work at the end
of this week, so reassigning to Pierre for fostering until ATSUI comes back.

Updated

19 years ago
Assignee: pierre → beard

Comment 5

19 years ago
Removed the [PP] tag because we don't need to get that fixed before the end of
the month and reassigning to beard who's watching over ATSUI issues.

Updated

19 years ago
Summary: [PP] Mac - Fonts rendered with jagged edges → Mac - Fonts rendered with jagged edges

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 6

19 years ago
Setting all current Open/Normal to M4.

Updated

19 years ago
QA Contact: 4110 → 4130

Comment 7

19 years ago
This is not a CSS bug (component set as 'Style System'). Reassigning qa contact
to claudius@netscape.com. Component needs reassignment.
(Reporter)

Updated

19 years ago
Component: Style System → Layout
(Reporter)

Comment 8

19 years ago
macdev folk say set component to layout for now

Updated

19 years ago
Target Milestone: M4 → M3

Comment 9

19 years ago
claudius, this still happen with latest Mac build on Apprunner?  I would Release
Note for Dogfood.

Comment 10

19 years ago
As far as my eyes can tell, there does not seem to be a problem with font smooting on the Mac as of tues 3/9 (99068) build. I do
not however, know the ATSUI status I'm assuming/hoping it's turned on? I also believe frank tang <ftang> is holding onto some
font/Atsui bugs so I've included him on the cc list.

Updated

19 years ago
Target Milestone: M3 → M4

Comment 11

19 years ago
teruko, how does this look for international?

Updated

19 years ago
Assignee: beard → ftang
Status: ASSIGNED → NEW

Updated

19 years ago
Assignee: ftang → beard

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M4 → M5

Comment 12

19 years ago
Moving to M5.

Updated

19 years ago
Summary: Mac - Fonts rendered with jagged edges → [PP]Mac - Fonts rendered with jagged edges

Updated

19 years ago
Target Milestone: M5 → M6

Comment 13

19 years ago
-> M6

Comment 14

19 years ago
Text is not completely visible in this page, might be a font metrics problem.
Are we doing font substitutions that may make this look bad? Take a look at:

http://www.cnn.com/NATURE/9905/14/glowing.mice.reut/

Updated

19 years ago
Target Milestone: M6 → M7

Comment 15

19 years ago
Keeps festering...

Updated

19 years ago
Target Milestone: M7 → M15

Updated

18 years ago
Assignee: beard → dcone
Status: ASSIGNED → NEW
Reassigning to Don.

Updated

18 years ago
Keywords: pp
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Summary: [PP]Mac - Fonts rendered with jagged edges → [FONT MAC]Mac - Fonts rendered with jagged edges

Comment 17

18 years ago
Is this still a problem ? I currently only use ATSUI in a very very limited way
so 99% time you won't hit ATSUI code unless there are some character we cannot
render by using MacRoman (such as 1/4, 1/2, and 3/4 characters)

Comment 18

18 years ago
QA to petersen, cc'ing sfraser
QA Contact: claudius → petersen
Keywords: fonts

Comment 19

18 years ago
I'm not seeing any noticeable font irregularities. Mozilla M15 2000031908, Mac
OS 9 (which should handle ATSUI code w/o any difference in quality, however).
(Assignee)

Updated

18 years ago
Target Milestone: M15 → M17
(Assignee)

Comment 20

18 years ago
The Fonts seem to be rendering smoothly, so I will close this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.