Open external applications by looking at the suffix

RESOLVED DUPLICATE of bug 90501

Status

()

Firefox
File Handling
--
enhancement
RESOLVED DUPLICATE of bug 90501
14 years ago
14 years ago

People

(Reporter: db, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I think this is Mac-specific.

I would like a preference where you can set Firefox to open an external
application with the AppleEvent URLEvent (or whatever it is called) if either
the file type (MIME type) or the suffix matches something.

Examples on when this would be useful is for mov, ics, rss, dmg, pdf, vcf etc.

*ics*
Even though ics just is text/plain (?) there is not much point in viewing it in
the browser. It would be much better if I could set iCal (or Mozilla;-) to open
it than either just viewing the raw source in a browser window or clutter my
download folder with calender-files. You can manually try this if you find an
ics-file somewhere and change the protocol from http:// to webcal://. If you
haven't changed anything in your system the address/download is handed over to iCal

*vcf*
Very much like ics, plain text but no point in viewing it in a browser or
downloading it to the download folder and then manually add it to the address
book (which leaves the original file untouched leading to a cluttered download
folder). If you change http to addressbook Address Book.app opens the vcf.

*rss*
Similar to ics and vcf.

*pdf, mov, dmg*
There are programs that handles all of these filetypes directly; Acrobat,
Quicktime Player and Disk Mounting Utility (name?) all accepts the URLEvent.


At the moment I manipulate the html source with privoxy but it does not work all
the time (specifically it only works when the link to the vcf, ics or dmg is
absolute), therefore I think this should be integrated in the browser. Maybe the
problem is that people use http for files that would do much better with a
different protocol (like webcal) but as long as we live in an imperfect world...

I understand that some people want to download all files and then manually take
care of them, that is the reason I think it should be a preference. Something like:

For files of the type/with the suffix
text/pdf                send the URL to external application: Acrobat
.vcf                    send the URL to external application Address Book.app


At the moment you can only decide which actions should apply depending on the
file type (MIME type) and you have no option to hand over the URL, just download
 or view with a plug-in.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
This request touches this comment
http://bugzilla.mozilla.org/show_bug.cgi?id=137339#c11
(Reporter)

Comment 2

14 years ago
It also touches http://bugzilla.mozilla.org/show_bug.cgi?id=90501 however, that
request is platform independent, this request is Mac-specific.

Comment 3

14 years ago
Couldn't this be fixed by checking the always open file with program xyz... that
is if you able to choose program xyz in the drop down box.

Comment 4

14 years ago
Despite my last comment... I think this can be considered a new/valid bug...
even if fixing bug 225574 resloves 90% of the issues related to this bug and it
doesn't seem wise to use an AppleScript to solve this probelm... redirectiong
the download stream of .vcf to the program of your choice would reduce download
clutter... and allowing Disk Utility or hdid to open .dmg files off a server my
be  a desirable to some users.

To me bug 90501 and bug 137339 are both requesting the same behavior as this bug.

Comment 5

14 years ago
I wonder if this is a dupe of bug 225882. They seem very very similar, but that
bug has to do with passing URIs to helper applications, whereas this bug also
encompasses passing entire files (like PDFs). I'm very tempted to dupe this bug
will hold off for now.

mconnor, any comments?

Comment 6

14 years ago
Moving to new File Handling component.
Component: Download Manager → File Handling
(In reply to comment #2)
> It also touches http://bugzilla.mozilla.org/show_bug.cgi?id=90501 however, that
> request is platform independent, this request is Mac-specific.

It is still a dupe (all/all doens't exculde mac :) )

*** This bug has been marked as a duplicate of 90501 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.