If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SELECT aren't themed if they have style="border:1px"

RESOLVED INVALID

Status

Core Graveyard
GFX: Win32
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Alfonso Martinez, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040421

If a SELECT has style="border:1px" then it isn't natively themed and the border
looks like a classic select box (I think that is 2px inset or something like that)

This is regression only in the trunk, the 1.7 branch keeps the same behaviour as
a week ago. 
the time of regression is between the 04-18-09 build and the 04-19-08 build
(both win32).

Looking at recently fixed bugs it looks to me (although I have no idea about the
Mozilla code) that this could be due to bug 237138 or bug 232175.



Reproducible: Always
Steps to Reproduce:
testcase:

<select>
	<option>style=""</option>
</select>			
<br>

<select style="border:1px">
	<option>style="border:1px"</option>
</select>			
<br>



Expected Results:  
If the web developer can't change the border width of the select at least use
the windows theme instead of the old 3D look.
(Reporter)

Comment 1

14 years ago
Created attachment 146806 [details]
Screenshot of the problem

A screenshot of 2 select box.
The first one doesn't have any style information and is rendered using the
windows theme.
The second one has border:1px and then it isn't themed AND the border isn't 1px
(Reporter)

Comment 2

14 years ago
Created attachment 146807 [details]
testcase of the problem

simple testcase used to take the screenshot.
(Reporter)

Updated

14 years ago
Keywords: regression, testcase
This is a result of bug 232175.  The problem is that the border IS part of the
native look.  That is, the native look includes a border.  If you change the
border, then you can't keep the native look (trying to will lead to various
sizing and painting bugs).

It's just like you can't change the color and keep the native look.

Comment 4

13 years ago
Created attachment 171334 [details]
Screenshot of Problem By Different User

The one on the left corresponds to using no background-color property.
.selectStyle {font-size: 10pt; font-family: arial,helvetica,sans-serif;
color:black;}

The one on the right corresponds to using the light blue background-color.
.selectStyle {font-size: 10pt; font-family: arial,helvetica,sans-serif;
color:black; background-color:#93bee2;}

Comment 5

13 years ago
Comment on attachment 171334 [details]
Screenshot of Problem By Different User

The one on the left corresponds to using no background-color property.
.selectStyle {font-size: 10pt; font-family: arial,helvetica,sans-serif;
color:black;}

The one on the right corresponds to using the light blue background-color.
.selectStyle {font-size: 10pt; font-family: arial,helvetica,sans-serif;
color:black; background-color:#93bee2;}
Invalid, per comment 3.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.